aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libyaml
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2006-09-01 17:50:25 +0800
committerijliao <ijliao@FreeBSD.org>2006-09-01 17:50:25 +0800
commit78963904a962917dbfd6ebbb24a50c73e4d2a861 (patch)
tree215594fc53c289214e7e9c7cee2b4786fb978284 /textproc/libyaml
parent02abe5b4fa533e7df698c27a147342ea103c2c67 (diff)
downloadfreebsd-ports-gnome-78963904a962917dbfd6ebbb24a50c73e4d2a861.tar.gz
freebsd-ports-gnome-78963904a962917dbfd6ebbb24a50c73e4d2a861.tar.zst
freebsd-ports-gnome-78963904a962917dbfd6ebbb24a50c73e4d2a861.zip
add libyaml 0.0.1
A YAML 1.1 parser and emitter written in C PR: 102712
Diffstat (limited to 'textproc/libyaml')
-rw-r--r--textproc/libyaml/Makefile27
-rw-r--r--textproc/libyaml/distinfo3
-rw-r--r--textproc/libyaml/files/patch-config-ltmain.sh15
-rw-r--r--textproc/libyaml/files/patch-tests-Makefile.in11
-rw-r--r--textproc/libyaml/pkg-descr23
5 files changed, 79 insertions, 0 deletions
diff --git a/textproc/libyaml/Makefile b/textproc/libyaml/Makefile
new file mode 100644
index 000000000000..55fff5bdfb43
--- /dev/null
+++ b/textproc/libyaml/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: libyaml
+# Date created: Aug 31, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libyaml
+PORTVERSION= 0.0.1
+CATEGORIES= textproc
+MASTER_SITES= http://pyyaml.org/download/libyaml/
+DISTNAME= yaml-${PORTVERSION}
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= A YAML 1.1 parser and emitter written in C
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/yaml.h \
+ lib/libyaml-0.so \
+ lib/libyaml-0.so.0 \
+ lib/libyaml.a \
+ lib/libyaml.so
+
+.include <bsd.port.mk>
diff --git a/textproc/libyaml/distinfo b/textproc/libyaml/distinfo
new file mode 100644
index 000000000000..02564354fbb0
--- /dev/null
+++ b/textproc/libyaml/distinfo
@@ -0,0 +1,3 @@
+MD5 (yaml-0.0.1.tar.gz) = 8affdebeb0da9ed6a4cefba210b432d4
+SHA256 (yaml-0.0.1.tar.gz) = a8f1b4910898eecdc611d6c0a527e225ce82fe3a030f344ee690b86c07c6f52e
+SIZE (yaml-0.0.1.tar.gz) = 410784
diff --git a/textproc/libyaml/files/patch-config-ltmain.sh b/textproc/libyaml/files/patch-config-ltmain.sh
new file mode 100644
index 000000000000..bee20d59e7a2
--- /dev/null
+++ b/textproc/libyaml/files/patch-config-ltmain.sh
@@ -0,0 +1,15 @@
+--- config/ltmain.sh.orig Thu Aug 31 09:21:40 2006
++++ config/ltmain.sh Thu Aug 31 09:21:52 2006
+@@ -6003,10 +6003,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/textproc/libyaml/files/patch-tests-Makefile.in b/textproc/libyaml/files/patch-tests-Makefile.in
new file mode 100644
index 000000000000..b4a0e315133f
--- /dev/null
+++ b/textproc/libyaml/files/patch-tests-Makefile.in
@@ -0,0 +1,11 @@
+--- tests/Makefile.in.orig Thu Aug 31 09:16:34 2006
++++ tests/Makefile.in Thu Aug 31 09:16:46 2006
+@@ -201,7 +201,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ AM_CPPFLAGS = -I$(top_srcdir)/include
+-AM_CFLAGS = -Wno-pointer-sign
++#AM_CFLAGS = -Wno-pointer-sign
+ LDADD = $(top_builddir)/src/libyaml.la
+ TESTS = test-version test-reader
+ all: all-am
diff --git a/textproc/libyaml/pkg-descr b/textproc/libyaml/pkg-descr
new file mode 100644
index 000000000000..6598ddbf198a
--- /dev/null
+++ b/textproc/libyaml/pkg-descr
@@ -0,0 +1,23 @@
+LibYAML is a YAML 1.1 parser and emitter written in C.
+
+LibYAML covers presenting and parsing processes. Thus LibYAML defines the
+following two processors:
+ * Parser, which takes an input stream of bytes and produces a sequence
+ of parsing events.
+ * Emitter, which takes a sequence of events and produces a stream of
+ bytes.
+
+The processes of parsing and presenting are inverse to each other. Any
+sequence of events produced by parsing a well-formed YAML document should
+be acceptable by the Emitter, which should produce an equivalent document.
+Similarly, any document produced by emitting a sequence of events should
+be acceptable for the Parser, which should produce an equivalent sequence
+of events.
+
+The job of resolving implicit tags, composing and serializing representation
+trees, as well as constructing and representing native objects is left to
+applications and bindings. Although some of these processes may be covered
+in the latter releases, they are not in the scope of the initial release of
+LibYAML.
+
+WWW: http://pyyaml.org/wiki/LibYAML