aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/loook
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-12-16 01:05:55 +0800
committernemysis <nemysis@FreeBSD.org>2013-12-16 01:05:55 +0800
commitfc255df875c11187307ec94b64beb98e9044024c (patch)
tree569c314f17739644953e37ce841746c0cbfa1fe1 /textproc/loook
parent0fc558b1e9570164e0c9b641bb569f66ed0eaa84 (diff)
downloadfreebsd-ports-gnome-fc255df875c11187307ec94b64beb98e9044024c.tar.gz
freebsd-ports-gnome-fc255df875c11187307ec94b64beb98e9044024c.tar.zst
freebsd-ports-gnome-fc255df875c11187307ec94b64beb98e9044024c.zip
Loook is a simple Python tool that searches for text strings in
LibreOffice and OpenOffice.org files. AND, OR and phrase searches are supported. It doesn't create an index, but searching should be fast enough unless you have really many files. WWW: http://www.danielnaber.de/loook/ PR: ports/171734 Submitted by: nemysis (self) Approved by: wg (mentor)
Diffstat (limited to 'textproc/loook')
-rw-r--r--textproc/loook/Makefile36
-rw-r--r--textproc/loook/distinfo2
-rw-r--r--textproc/loook/pkg-descr7
3 files changed, 45 insertions, 0 deletions
diff --git a/textproc/loook/Makefile b/textproc/loook/Makefile
new file mode 100644
index 000000000000..016af47ffac4
--- /dev/null
+++ b/textproc/loook/Makefile
@@ -0,0 +1,36 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= loook
+PORTVERSION= 0.6.5
+CATEGORIES= textproc
+MASTER_SITES= http://www.danielnaber.de/loook/
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= python
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Simple Python tool that search in LibreOffice/OpenOffice files
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>=0:${PORTSDIR}/x11-toolkits/py-tkinter \
+ ${PYTHON_PKGNAMEPREFIX}iniparse>=0:${PORTSDIR}/devel/py-iniparse
+
+WRKSRC= ${WRKDIR}
+
+USE_ZIP= yes
+USE_PYTHON= 2.7
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|' \
+ ${WRKSRC}/${PORTNAME}.py
+ @(cd ${WRKSRC} ; ${RM} *.py.bak)
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/textproc/loook/distinfo b/textproc/loook/distinfo
new file mode 100644
index 000000000000..28887d003d08
--- /dev/null
+++ b/textproc/loook/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python/loook.zip) = 65cb98991b9e6322af60a7ef1b47c429ad12ec50774375e46a5c733995eccfd4
+SIZE (python/loook.zip) = 11860
diff --git a/textproc/loook/pkg-descr b/textproc/loook/pkg-descr
new file mode 100644
index 000000000000..975cfc6efb77
--- /dev/null
+++ b/textproc/loook/pkg-descr
@@ -0,0 +1,7 @@
+Loook is a simple Python tool that searches for text strings in
+LibreOffice and OpenOffice.org files.
+
+AND, OR and phrase searches are supported. It doesn't create an index,
+but searching should be fast enough unless you have really many files.
+
+WWW: http://www.danielnaber.de/loook/