aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ltxml/Makefile
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2000-11-01 10:32:33 +0800
committerjeh <jeh@FreeBSD.org>2000-11-01 10:32:33 +0800
commit8291790750e0dfcc6f5593fd977e169088cdf596 (patch)
tree60b4d869c40cf169511999385a0b966006f107f1 /textproc/ltxml/Makefile
parent4c5179232d03273a19e434465d8a98459a554b2f (diff)
downloadfreebsd-ports-gnome-8291790750e0dfcc6f5593fd977e169088cdf596.tar.gz
freebsd-ports-gnome-8291790750e0dfcc6f5593fd977e169088cdf596.tar.zst
freebsd-ports-gnome-8291790750e0dfcc6f5593fd977e169088cdf596.zip
New Port: textproc/ltxml
Integrated set of XML tools and a developers' tool-kit. PR: 22183 Submitted by: Samuel Tardieu <sam@inf.enst.fr>
Diffstat (limited to 'textproc/ltxml/Makefile')
-rw-r--r--textproc/ltxml/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/textproc/ltxml/Makefile b/textproc/ltxml/Makefile
new file mode 100644
index 000000000000..6d1e29fef2d6
--- /dev/null
+++ b/textproc/ltxml/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: LT XML
+# Date created: 20 Oct 2000
+# Whom: Samuel Tardieu <sam@inf.enst.fr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ltxml
+PORTVERSION= 1.2
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.cogsci.ed.ac.uk/pub/LTXML/
+
+MAINTAINER= sam@inf.enst.fr
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/XML
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-zlib
+USE_GMAKE= yes
+
+post-install:
+ strip ${PREFIX}/bin/sgmltoken
+ strip ${PREFIX}/bin/unknit
+ strip ${PREFIX}/bin/sgmlsb
+ strip ${PREFIX}/bin/simple
+ strip ${PREFIX}/bin/textonly
+ strip ${PREFIX}/bin/simpleq
+ strip ${PREFIX}/bin/sggrep
+ strip ${PREFIX}/bin/sgcount
+ strip ${PREFIX}/bin/sgmltrans
+ strip ${PREFIX}/bin/getindex
+ strip ${PREFIX}/bin/sgsort
+ strip ${PREFIX}/bin/xmlnorm
+ strip ${PREFIX}/bin/knit
+ strip ${PREFIX}/bin/nslwhere
+ strip ${PREFIX}/bin/pesis
+ strip ${PREFIX}/bin/sgrpg
+ strip ${PREFIX}/bin/nslshowddb
+ strip ${PREFIX}/bin/intersect
+
+MAN1= ltxml.1 xmlnorm.1 pesis.1 sgcount.1 sggrep.1 \
+ sgmlsb.1 sgmlseg.1 sgmltoken.1 sgmltrans.1 \
+ sgrpg.1 textonly.1 unknit.1 sgsort.1 \
+ nslwhere.1 knit.1 nslshowddb.1 getindex.1
+
+MAN5= ltxml-query.5
+
+.include <bsd.port.mk>