aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ltxml/Makefile
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-10-17 09:24:54 +0800
committerwen <wen@FreeBSD.org>2011-10-17 09:24:54 +0800
commitf2494897b1535fc49ea0b07cbe493299cf718a78 (patch)
tree553c0a5b66b38e5d4eec8f30a18a216137ab5861 /textproc/ltxml/Makefile
parentb30ae927bb386d70daa921486eea13390976f9b2 (diff)
downloadfreebsd-ports-gnome-f2494897b1535fc49ea0b07cbe493299cf718a78.tar.gz
freebsd-ports-gnome-f2494897b1535fc49ea0b07cbe493299cf718a78.tar.zst
freebsd-ports-gnome-f2494897b1535fc49ea0b07cbe493299cf718a78.zip
- Update to 1.2.9
PR: ports/161656 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'textproc/ltxml/Makefile')
-rw-r--r--textproc/ltxml/Makefile42
1 files changed, 12 insertions, 30 deletions
diff --git a/textproc/ltxml/Makefile b/textproc/ltxml/Makefile
index e28140e4ac50..4ea109a6d462 100644
--- a/textproc/ltxml/Makefile
+++ b/textproc/ltxml/Makefile
@@ -6,43 +6,30 @@
#
PORTNAME= ltxml
-PORTVERSION= 1.2.7
+PORTVERSION= 1.2.9
CATEGORIES= textproc
-MASTER_SITES= #
+MASTER_SITES= GENTOO/distfiles \
+ ftp://ftp.cogsci.ed.ac.uk/pub/LTXML/
MAINTAINER= ports@FreeBSD.org
COMMENT= XML Toolkit
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKDIR}/${DISTNAME}/COPYING
+
+OPTIONS= OPTIMIZED_CFLAGS "Extra optimizations" off
+
WRKSRC= ${WRKDIR}/${DISTNAME}/XML
USE_PERL5= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-zlib=/usr --enable-multi-byte
-
-MAN1= ltxml.1 xmlnorm.1 pesis.1 sgcount.1 sggrep.1 sgmlsb.1 \
- sgmlseg.1 sgmltoken.1 sgmltrans.1 sgrpg.1 textonly.1 \
- unknit.1 sgsort.1 nslwhere.1 knit.1 nslshowddb.1 getindex.1
-MAN5= ltxml-query.5
-
-PROGRAMS= getindex intersect knit nslshowddb nslwhere pesis sgcount \
- sggrep sgmlsb sgmlseg sgmltrans sgrpg sgsort simple simpleq \
- textonly unknit xmlnorm
-
-OPTIONS= OPTIMIZED_CFLAGS "Extra optimizations" off
+CONFIGURE_ARGS= --with-zlib=/usr --datadir=${PREFIX}/lib/ltxml12
+MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-ECHO_MSG=/usr/bin/printf
-IGNORE= :\n\
-You have to download the distribution manually from \n\
-http://www.inf.ed.ac.uk/research/isdd/admin/package?download=74.\n\
-Download the file ${DISTNAME}${EXTRACT_SUFX}, and place it in\n\
-${DISTDIR}.\n
-.endif
-
-.ifdef WITH_OPTIMIZED_CFLAGS
+.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations -O3
.endif
@@ -50,13 +37,8 @@ CFLAGS+= -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fe
CFLAGS+= -fPIC
.endif
-post-install:
-.for file in ${PROGRAMS:S/sgmlseg//}
- ${STRIP_CMD} ${PREFIX}/bin/${file}
-.endfor
-
post-patch:
- @${PERL} -pi -e 's|CFLAGS=.*$$|CFLAGS=\$$CFLAGS|g ; \
+ @${REINPLACE_CMD} -e 's|CFLAGS=.*$$|CFLAGS=\$$CFLAGS|g ; \
s|CXXFLAGS=.*$$|CXXFLAGS=\$$CXXFLAGS|g' ${WRKSRC}/configure
.include <bsd.port.post.mk>