aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/maketeidtd/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-01-04 07:23:26 +0800
committeredwin <edwin@FreeBSD.org>2003-01-04 07:23:26 +0800
commit9b4412fe3e470570f9a96b8ef9ae0b3c73d5a15e (patch)
treee05cc7fa4ce8866efb55a558a1e90c325577e380 /textproc/maketeidtd/Makefile
parenta3f32fb6b791192824f278d49197c1fa90fff83e (diff)
downloadfreebsd-ports-gnome-9b4412fe3e470570f9a96b8ef9ae0b3c73d5a15e.tar.gz
freebsd-ports-gnome-9b4412fe3e470570f9a96b8ef9ae0b3c73d5a15e.tar.zst
freebsd-ports-gnome-9b4412fe3e470570f9a96b8ef9ae0b3c73d5a15e.zip
New Port: Customize TEI DTDs
Generate customized TEI-DTDs PR: ports/38341 Submitted by: Henrik Motakef <henrik.motakef@web.de>
Diffstat (limited to 'textproc/maketeidtd/Makefile')
-rw-r--r--textproc/maketeidtd/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/textproc/maketeidtd/Makefile b/textproc/maketeidtd/Makefile
new file mode 100644
index 000000000000..4774446b8d4a
--- /dev/null
+++ b/textproc/maketeidtd/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: maketeidtd
+# Date created: 18 May 2002
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= maketeidtd
+PORTVERSION= 20020414 # Cannot find a "real" version number
+CATEGORIES= textproc
+MASTER_SITES= http://www.tei-c.org/Software/maketeidtd/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= henrik.motakef@web.de
+
+RUN_DEPENDS= carthage:${PORTSDIR}/textproc/carthage \
+ ${LOCALBASE}/share/sgml/tei/p4/tei2.dtd:${PORTSDIR}/textproc/tei-p4
+
+USE_PERL5= yes
+USE_ZIP= yes
+NO_BUILD= yes
+
+post-patch:
+ @${MV} ${WRKSRC}/maketeidtd ${WRKSRC}/maketeidtd.tmp
+ @${SED} -e 's;#!/usr/bin/perl;#!${PERL};' \
+ -e 's;../../P4X/DTD;${PREFIX}/share/sgml/tei/p4;' \
+ ${WRKSRC}/maketeidtd.tmp > ${WRKSRC}/maketeidtd
+ @${RM} ${WRKSRC}/maketeidtd.tmp
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/maketeidtd ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/maketeidtd
+ @${MKDIR} ${PREFIX}/share/examples/maketeidtd
+ @${INSTALL_MAN} ${WRKSRC}/index.html ${PREFIX}/share/doc/maketeidtd
+ @${INSTALL_MAN} ${WRKSRC}/index.xml ${PREFIX}/share/doc/maketeidtd
+ @${INSTALL_MAN} ${WRKSRC}/index.xsl ${PREFIX}/share/doc/maketeidtd
+ @${INSTALL_MAN} ${WRKSRC}/examples/* ${PREFIX}/share/examples/maketeidtd
+.endif
+
+.include <bsd.port.mk>