aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/mifluz/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-11-22 21:33:06 +0800
committermiwi <miwi@FreeBSD.org>2007-11-22 21:33:06 +0800
commit97b30fe28e3c21456556c71f5c24ade914616536 (patch)
tree18b8a01a6dc373d783246c2f035edee69fd27104 /textproc/mifluz/Makefile
parent4ff6974c938dd05d572c8d72d6519244060403fb (diff)
downloadfreebsd-ports-gnome-97b30fe28e3c21456556c71f5c24ade914616536.tar.gz
freebsd-ports-gnome-97b30fe28e3c21456556c71f5c24ade914616536.tar.zst
freebsd-ports-gnome-97b30fe28e3c21456556c71f5c24ade914616536.zip
- Fix build with gcc 4.2
PR: 118197 Submitted by: Pietro Cerutti <gahr@gahr.ch> Approved by: portmgr (erwin)
Diffstat (limited to 'textproc/mifluz/Makefile')
-rw-r--r--textproc/mifluz/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/textproc/mifluz/Makefile b/textproc/mifluz/Makefile
index 46d5b01478f1..4fb37feb766f 100644
--- a/textproc/mifluz/Makefile
+++ b/textproc/mifluz/Makefile
@@ -19,9 +19,9 @@ USE_ICONV= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} --without-unac
USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool:15
USE_BISON= build
-USE_GCC= 2.95
MAN1= htdb_dump.1 htdb_stat.1 htdb_load.1 mifluzdump.1 mifluzload.1 \
mifluzsearch.1 mifluzdict.1
@@ -35,7 +35,9 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
post-patch:
@${REINPLACE_CMD} 's|-D_THREAD_SAFE -pthread|${PTHREAD_CFLAGS}|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ s|-lpthread|${PTHREAD_LIBS}|g ;\
+ s|echo aout|echo elf|g' \
+ ${WRKSRC}/configure
post-install:
@${SED} -e "s:%%PREFIX%%:${PREFIX}:g" ${PKGDIR}/pkg-message > \
@@ -44,10 +46,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= fails to install
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>