aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/nltk/files/patch-setup.py
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-09-12 02:01:59 +0800
committerrm <rm@FreeBSD.org>2012-09-12 02:01:59 +0800
commit5638eef0409152cd6b433c8850a3abf56dfc8b9e (patch)
treeac3573f46b5b4ad0d23d1097eb3fce73cb429a2c /textproc/nltk/files/patch-setup.py
parent808f27cdbc8e35f3ac3e26249101367bcd150b5e (diff)
downloadfreebsd-ports-gnome-5638eef0409152cd6b433c8850a3abf56dfc8b9e.tar.gz
freebsd-ports-gnome-5638eef0409152cd6b433c8850a3abf56dfc8b9e.tar.zst
freebsd-ports-gnome-5638eef0409152cd6b433c8850a3abf56dfc8b9e.zip
- update to 2.0.2
- change mastersites to pypi, because google doesn't carry the latest tarball - drop unneeded BUILD_DEPENDS, LICENSE_FILE, USE_PYTHON_PREFIX, PYDISTUTILS_EGGINFO - create pkg-plist - install with setuptools (upstream switched to it via distribute) - strict python versions to 2.x only - add patch to not use distribute for installing. distribute conflicts with setuptools. this may be dropped when the whole ports tree will be switched to distribute. PR: 170515 Submitted by: rm (myself) Approved by: maintainer timeout (1 month)
Diffstat (limited to 'textproc/nltk/files/patch-setup.py')
-rw-r--r--textproc/nltk/files/patch-setup.py12
1 files changed, 12 insertions, 0 deletions
diff --git a/textproc/nltk/files/patch-setup.py b/textproc/nltk/files/patch-setup.py
new file mode 100644
index 000000000000..dbd4deb98513
--- /dev/null
+++ b/textproc/nltk/files/patch-setup.py
@@ -0,0 +1,12 @@
+--- setup.py.orig 2012-02-06 14:55:59.000000000 +0400
++++ setup.py 2012-08-09 14:41:28.000000000 +0400
+@@ -19,9 +19,6 @@
+ with open(version_file) as fh:
+ nltk_version = fh.read().strip()
+
+-import distribute_setup
+-distribute_setup.use_setuptools()
+-
+ from setuptools import setup, find_packages
+
+ #