aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/openjade/Makefile
diff options
context:
space:
mode:
authorjfieber <jfieber@FreeBSD.org>1997-06-23 04:28:13 +0800
committerjfieber <jfieber@FreeBSD.org>1997-06-23 04:28:13 +0800
commitc2fd0294a926f74d4b54c46f2220b0bf97919939 (patch)
treebd1df751d7358760cff53ac91de913ec76dcdc1e /textproc/openjade/Makefile
parent8b2539b7d4f4b6a7b793857c82a6a4084a25e048 (diff)
downloadfreebsd-ports-gnome-c2fd0294a926f74d4b54c46f2220b0bf97919939.tar.gz
freebsd-ports-gnome-c2fd0294a926f74d4b54c46f2220b0bf97919939.tar.zst
freebsd-ports-gnome-c2fd0294a926f74d4b54c46f2220b0bf97919939.zip
Jade: a DSSSL processor.
Note, this port is a superset of the SP port, but unlike SP this one will not compile on FreeBSD 2.1.x--a more modern C++ compiler is needed.
Diffstat (limited to 'textproc/openjade/Makefile')
-rw-r--r--textproc/openjade/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/openjade/Makefile b/textproc/openjade/Makefile
new file mode 100644
index 000000000000..43b4b8fd826c
--- /dev/null
+++ b/textproc/openjade/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: jade
+# Version required: 0.8
+# Date created: June 19, 1997
+# Whom: jfieber
+#
+# $Id$
+#
+
+DISTNAME= jade-0.8
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.jclark.com/pub/jade/
+
+MAINTAINER= jfieber@FreeBSD.ORG
+
+DISTFILES= jade0_8.zip
+EXTRACT_CMD= unzip
+EXTRACT_BEFORE_ARGS= -a -U -qq
+
+NO_WRKSUBDIR=
+
+# Unfortunately, jade needs a more modern C++ compiler than
+# comes with FreeBSD 2.1.x.
+.if !exists(/usr/lib/libstdc++.a)
+BROKEN= yes
+.endif
+
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+post-install:
+ /sbin/ldconfig -m ${PREFIX}/lib
+
+.include <bsd.port.mk>