aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/opentoken/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-03-14 21:43:26 +0800
committermarino <marino@FreeBSD.org>2014-03-14 21:43:26 +0800
commitb06c634905cb5ea6b9157660fdc3b1524f15cce4 (patch)
tree7ead97861fe1c187a5465c96a4fe952a0e6484e2 /textproc/opentoken/Makefile
parenta3a8ef68a586c478b72e7d563af0845fbbafe1d0 (diff)
downloadfreebsd-ports-gnome-b06c634905cb5ea6b9157660fdc3b1524f15cce4.tar.gz
freebsd-ports-gnome-b06c634905cb5ea6b9157660fdc3b1524f15cce4.tar.zst
freebsd-ports-gnome-b06c634905cb5ea6b9157660fdc3b1524f15cce4.zip
Add new Ada port: textproc/opentoken 5.0a
OpenToken is a facility for performing token analysis and parsing within the Ada language. It is designed to provide all the functionality of a traditional lexical analyzer/parser generator, such as lex/yacc. But due to the magic of inheritance and runtime polymorphism it is implemented entirely in Ada as withed-in code. No precompilation step is required, and no messy tool-generated source code is created. The tradeoff is that the grammar is generated at runtime. WWW: http://stephe-leake.org/ada/opentoken.html
Diffstat (limited to 'textproc/opentoken/Makefile')
-rw-r--r--textproc/opentoken/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/textproc/opentoken/Makefile b/textproc/opentoken/Makefile
new file mode 100644
index 000000000000..c3cbf0a28568
--- /dev/null
+++ b/textproc/opentoken/Makefile
@@ -0,0 +1,43 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= opentoken
+PORTVERSION= 5.0a
+CATEGORIES= textproc
+MASTER_SITES= http://stephe-leake.org/ada/
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= Lexical analyser and parser for the Ada language
+
+LICENSE= GPLv3 GPLv3RLE
+LICENSE_COMB= multi
+
+BUILD_DEPENDS= gprbuild>=20130416:${PORTSDIR}/devel/gprbuild
+
+USES= ada tar:bzip2
+
+WRKSRC= ${WRKDIR}/org.${PORTNAME}-${PORTVERSION}
+BUILD_WRKSRC= ${WRKSRC}/build/release
+OTLIBVER= 5.0.0
+PLIST_SUB+= OTLIBVER=${OTLIBVER}
+
+do-build:
+ (cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ gprbuild -p -P opentoken_lib )
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/gnat \
+ ${STAGEDIR}${PREFIX}/lib/opentoken \
+ ${STAGEDIR}${PREFIX}/include/opentoken
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/lib/*.ali \
+ ${STAGEDIR}${PREFIX}/lib/opentoken
+ ${INSTALL_LIB} ${BUILD_WRKSRC}/lib/libopentoken.so.${OTLIBVER} \
+ ${STAGEDIR}${PREFIX}/lib/opentoken
+ (cd ${STAGEDIR}${PREFIX}/lib/opentoken && \
+ ${LN} -s libopentoken.so.${OTLIBVER} libopentoken.so)
+ ${INSTALL_DATA} ${WRKSRC}/*.ad[bs] ${WRKSRC}/Language_Lexers/*.ad[bs] \
+ ${STAGEDIR}${PREFIX}/include/opentoken
+ ${INSTALL_DATA} ${FILESDIR}/opentoken.gpr \
+ ${STAGEDIR}${PREFIX}/lib/gnat
+
+.include <bsd.port.mk>