aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Data-Report
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2006-05-24 19:10:48 +0800
committertobez <tobez@FreeBSD.org>2006-05-24 19:10:48 +0800
commitc76760f0fba5989df4b9ca1019f0f5cfddd6da71 (patch)
tree8cfc530bd75c16fd1e4820589858d33debde41cc /textproc/p5-Data-Report
parent9d252abb466f6c7d7274c49a37ac783e84dc9725 (diff)
downloadfreebsd-ports-gnome-c76760f0fba5989df4b9ca1019f0f5cfddd6da71.tar.gz
freebsd-ports-gnome-c76760f0fba5989df4b9ca1019f0f5cfddd6da71.tar.zst
freebsd-ports-gnome-c76760f0fba5989df4b9ca1019f0f5cfddd6da71.zip
Add p5-Data-Report - a framework for flexible reporting.
Diffstat (limited to 'textproc/p5-Data-Report')
-rw-r--r--textproc/p5-Data-Report/Makefile35
-rw-r--r--textproc/p5-Data-Report/distinfo3
-rw-r--r--textproc/p5-Data-Report/pkg-descr23
-rw-r--r--textproc/p5-Data-Report/pkg-plist11
4 files changed, 72 insertions, 0 deletions
diff --git a/textproc/p5-Data-Report/Makefile b/textproc/p5-Data-Report/Makefile
new file mode 100644
index 000000000000..776868b0b728
--- /dev/null
+++ b/textproc/p5-Data-Report/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: textproc/p5-Data-Report
+# Date created: 24 May 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Report
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Data::Report - Framework for flexible reporting
+
+COMMON_DEPENDS= p5-HTML-Parser>0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-Text-CSV_XS>0:${PORTSDIR}/textproc/p5-Text-CSV_XS
+BUILD_DEPENDS= p5-Module-Build>=0.28:${PORTSDIR}/devel/p5-Module-Build \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
+ ${COMMON_DEPENDS}
+RUN_DEPENDS= ${COMMON_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Data::Report.3 Data::Report::API.3 Data::Report::Base.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Data-Report/distinfo b/textproc/p5-Data-Report/distinfo
new file mode 100644
index 000000000000..6d30d738b18d
--- /dev/null
+++ b/textproc/p5-Data-Report/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Report-0.03.tar.gz) = 9baa612b3b25d03e4c0f73db17cb8809
+SHA256 (Data-Report-0.03.tar.gz) = 15c6e39c69ed2e32a6d1e1362942cd7c301b93af2fcee99f652fa2da706a6418
+SIZE (Data-Report-0.03.tar.gz) = 15936
diff --git a/textproc/p5-Data-Report/pkg-descr b/textproc/p5-Data-Report/pkg-descr
new file mode 100644
index 000000000000..024ef98b10dd
--- /dev/null
+++ b/textproc/p5-Data-Report/pkg-descr
@@ -0,0 +1,23 @@
+Data::Report is a flexible, plugin-driven reporting framework.
+
+The Data::Report framework consists of three parts:
+
+- the plugins
+
+Plugins implement a specific type of report. Standard plugins provided
+are Data::Report::Plugin::Text for textual reports,
+Data::Report::Plugin::Html for HTML reports, and
+Data::Report::Plugin::Csv for CSV (comma-separated) files.
+
+- the base class
+
+The base class Data::Report::Base implements the functionality common to
+all reporters, plus a number of utility functions the plugins can use.
+
+- the factory
+
+The actual Data::Report module is a factory that creates a reporter for
+a given report type by selecting the appropriate plugin and returning an
+instance thereof.
+
+WWW: http://search.cpan.org/dist/Data-Report/
diff --git a/textproc/p5-Data-Report/pkg-plist b/textproc/p5-Data-Report/pkg-plist
new file mode 100644
index 000000000000..a8d9ee6bbadb
--- /dev/null
+++ b/textproc/p5-Data-Report/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Report/.packlist
+%%SITE_PERL%%/Data/Report.pm
+%%SITE_PERL%%/Data/Report/API.pm
+%%SITE_PERL%%/Data/Report/Base.pm
+%%SITE_PERL%%/Data/Report/Plugin/Csv.pm
+%%SITE_PERL%%/Data/Report/Plugin/Html.pm
+%%SITE_PERL%%/Data/Report/Plugin/Text.pm
+@dirrmtry %%SITE_PERL%%/Data/Report/Plugin
+@dirrmtry %%SITE_PERL%%/Data/Report
+@dirrmtry %%SITE_PERL%%/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Report