aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Lingua-EN-MatchNames/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2002-06-09 06:33:42 +0800
committerpetef <petef@FreeBSD.org>2002-06-09 06:33:42 +0800
commitffc0026d8208485ec0cdebd187eda7b1c5d72288 (patch)
tree78a9db045a6456e63292b530de7ed4d7d51ab4de /textproc/p5-Lingua-EN-MatchNames/Makefile
parent1d8ddb583ac3ca8025c1ecd8b55db0621eaf0fd7 (diff)
downloadfreebsd-ports-gnome-ffc0026d8208485ec0cdebd187eda7b1c5d72288.tar.gz
freebsd-ports-gnome-ffc0026d8208485ec0cdebd187eda7b1c5d72288.tar.zst
freebsd-ports-gnome-ffc0026d8208485ec0cdebd187eda7b1c5d72288.zip
Add p5-Lingua-EN-MatchNames 1.1, smart matching for human names.
PR: 33379 Submitted by: Seamus Venasse <svenasse@polaris.ca>
Diffstat (limited to 'textproc/p5-Lingua-EN-MatchNames/Makefile')
-rw-r--r--textproc/p5-Lingua-EN-MatchNames/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/p5-Lingua-EN-MatchNames/Makefile b/textproc/p5-Lingua-EN-MatchNames/Makefile
new file mode 100644
index 000000000000..11c17f59349f
--- /dev/null
+++ b/textproc/p5-Lingua-EN-MatchNames/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Lingua::EN::MatchNames
+# Date created: 30 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Lingua-EN-MatchNames
+PORTVERSION= 1.1
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Lingua
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/Lingua/EN/NameParse.pm:${PORTSDIR}/textproc/p5-Lingua-EN-NameParse \
+ ${SITE_PERL}/Lingua/EN/Nickname.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Nickname \
+ ${SITE_PERL}/${PERL_ARCH}/String/Approx.pm:${PORTSDIR}/devel/p5-String-Approx \
+ ${SITE_PERL}/${PERL_ARCH}/Text/Metaphone.pm:${PORTSDIR}/textproc/p5-Text-Metaphone
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3= Lingua::EN::MatchNames.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>