aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Lingua-EN-NameParse/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2002-01-27 12:56:52 +0800
committerpetef <petef@FreeBSD.org>2002-01-27 12:56:52 +0800
commit1f7d66c29cc7a83a611438835ac57def3c933191 (patch)
tree6cdfe27ab3f43e18b00ab6cc9296366d87bdae1c /textproc/p5-Lingua-EN-NameParse/Makefile
parent34a992376e3ead888b8b9deca152f8548cc2af16 (diff)
downloadfreebsd-ports-gnome-1f7d66c29cc7a83a611438835ac57def3c933191.tar.gz
freebsd-ports-gnome-1f7d66c29cc7a83a611438835ac57def3c933191.tar.zst
freebsd-ports-gnome-1f7d66c29cc7a83a611438835ac57def3c933191.zip
Add p5-Lingua-EN-NameParse 1.16, perl routines for manipulating a
person's name. PR: 33381 Submitted by: Seamus Venasse <svenasse@polaris.ca>
Diffstat (limited to 'textproc/p5-Lingua-EN-NameParse/Makefile')
-rw-r--r--textproc/p5-Lingua-EN-NameParse/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/p5-Lingua-EN-NameParse/Makefile b/textproc/p5-Lingua-EN-NameParse/Makefile
new file mode 100644
index 000000000000..3c7f82ff30b4
--- /dev/null
+++ b/textproc/p5-Lingua-EN-NameParse/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Lingua::EN::NameParse
+# Date created: 30 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Lingua-EN-NameParse
+PORTVERSION= 1.16
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Lingua
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3= Lingua::EN::NameGrammar.3 \
+ Lingua::EN::NameParse.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>