aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-OpenOffice-OODoc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-10-21 17:16:05 +0800
committermiwi <miwi@FreeBSD.org>2009-10-21 17:16:05 +0800
commit10c2b5b6ac9965e12931df3fc4021c7b6053c30e (patch)
tree6bd4a90c65636739b84290e001184e75c9af0072 /textproc/p5-OpenOffice-OODoc
parent2121d6d5b4dc2a5b1f29ec608266ed1526fdb01b (diff)
downloadfreebsd-ports-gnome-10c2b5b6ac9965e12931df3fc4021c7b6053c30e.tar.gz
freebsd-ports-gnome-10c2b5b6ac9965e12931df3fc4021c7b6053c30e.tar.zst
freebsd-ports-gnome-10c2b5b6ac9965e12931df3fc4021c7b6053c30e.zip
OpenOffice::OODoc is an extensible Perl interface allowing direct
read/write operations on files which comply with the OASIS Open Document Format for Office Applications (ODF), i.e. the ISO/IEC 26300:2006 standard. It provides a high-level, document-oriented language, and isolates the programmer from the details of the file format. It can process different document classes (texts, spreadsheets, presentations, and drawings). It can retrieve or update styles and images, document metadata, as well as text content. WWW: http://search.cpan.org/dist/OpenOffice-OODoc/ PR: ports/139548 Submitted by: meyser at xenet.de
Diffstat (limited to 'textproc/p5-OpenOffice-OODoc')
-rw-r--r--textproc/p5-OpenOffice-OODoc/Makefile32
-rw-r--r--textproc/p5-OpenOffice-OODoc/distinfo3
-rw-r--r--textproc/p5-OpenOffice-OODoc/pkg-descr12
-rw-r--r--textproc/p5-OpenOffice-OODoc/pkg-plist51
4 files changed, 98 insertions, 0 deletions
diff --git a/textproc/p5-OpenOffice-OODoc/Makefile b/textproc/p5-OpenOffice-OODoc/Makefile
new file mode 100644
index 000000000000..1b8dc4708f2b
--- /dev/null
+++ b/textproc/p5-OpenOffice-OODoc/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: OpenOffice::OODoc
+# Date created: 10 October 2009
+# Whom: meyser@xenet.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= OpenOffice-OODoc
+PORTVERSION= 2.108
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= meyser@xenet.de
+COMMENT= The Perl Open OpenDocument Connector
+
+RUN_DEPENDS= p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip \
+ p5-XML-Twig>=0:${PORTSDIR}/textproc/p5-XML-Twig
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= --noprompt
+
+MAN1= odf2pod.1 odf_set_fields.1 odf_set_title.1 odfbuild.1 \
+ odfextract.1 odffilesearch.1 odffindbasic.1 odfhighlight.1 \
+ odfmetadoc.1 odfsearch.1 oodoc_test.1 text2odf.1 text2table.1
+MAN3= OpenOffice::OODoc.3 OpenOffice::OODoc::Document.3 \
+ OpenOffice::OODoc::File.3 OpenOffice::OODoc::Image.3 \
+ OpenOffice::OODoc::Intro.3 OpenOffice::OODoc::Manifest.3 \
+ OpenOffice::OODoc::Meta.3 OpenOffice::OODoc::Styles.3 \
+ OpenOffice::OODoc::Text.3 OpenOffice::OODoc::XPath.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-OpenOffice-OODoc/distinfo b/textproc/p5-OpenOffice-OODoc/distinfo
new file mode 100644
index 000000000000..865a536f5bc1
--- /dev/null
+++ b/textproc/p5-OpenOffice-OODoc/distinfo
@@ -0,0 +1,3 @@
+MD5 (OpenOffice-OODoc-2.108.tar.gz) = 745c6ba13360d005447451b2ed8b8ff0
+SHA256 (OpenOffice-OODoc-2.108.tar.gz) = 0f3c81e39b62ccc08d750b26b14af4c3db9f8435fa7d3bc85b256009ed088ab2
+SIZE (OpenOffice-OODoc-2.108.tar.gz) = 278758
diff --git a/textproc/p5-OpenOffice-OODoc/pkg-descr b/textproc/p5-OpenOffice-OODoc/pkg-descr
new file mode 100644
index 000000000000..5652161cb2a2
--- /dev/null
+++ b/textproc/p5-OpenOffice-OODoc/pkg-descr
@@ -0,0 +1,12 @@
+OpenOffice::OODoc is an extensible Perl interface allowing direct
+read/write operations on files which comply with the
+OASIS Open Document Format for Office Applications (ODF),
+i.e. the ISO/IEC 26300:2006 standard.
+
+It provides a high-level, document-oriented language, and isolates
+the programmer from the details of the file format. It can process
+different document classes (texts, spreadsheets, presentations,
+and drawings). It can retrieve or update styles and images,
+document metadata, as well as text content.
+
+WWW: http://search.cpan.org/dist/OpenOffice-OODoc/
diff --git a/textproc/p5-OpenOffice-OODoc/pkg-plist b/textproc/p5-OpenOffice-OODoc/pkg-plist
new file mode 100644
index 000000000000..6d5a9573a160
--- /dev/null
+++ b/textproc/p5-OpenOffice-OODoc/pkg-plist
@@ -0,0 +1,51 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenOffice/OODoc/.packlist
+%%SITE_PERL%%/OpenOffice/OODoc.pod
+%%SITE_PERL%%/OpenOffice/OODoc.pm
+%%SITE_PERL%%/OpenOffice/OODoc/Styles.pod
+%%SITE_PERL%%/OpenOffice/OODoc/File.pod
+%%SITE_PERL%%/OpenOffice/OODoc/Manifest.pod
+%%SITE_PERL%%/OpenOffice/OODoc/Image.pod
+%%SITE_PERL%%/OpenOffice/OODoc/Manifest.pm
+%%SITE_PERL%%/OpenOffice/OODoc/config.xml
+%%SITE_PERL%%/OpenOffice/OODoc/XPath.pm
+%%SITE_PERL%%/OpenOffice/OODoc/Meta.pod
+%%SITE_PERL%%/OpenOffice/OODoc/File.pm
+%%SITE_PERL%%/OpenOffice/OODoc/Styles.pm
+%%SITE_PERL%%/OpenOffice/OODoc/Image.pm
+%%SITE_PERL%%/OpenOffice/OODoc/Meta.pm
+%%SITE_PERL%%/OpenOffice/OODoc/XPath.pod
+%%SITE_PERL%%/OpenOffice/OODoc/Document.pm
+%%SITE_PERL%%/OpenOffice/OODoc/Intro.pod
+%%SITE_PERL%%/OpenOffice/OODoc/Text.pod
+%%SITE_PERL%%/OpenOffice/OODoc/Text.pm
+%%SITE_PERL%%/OpenOffice/OODoc/Document.pod
+%%SITE_PERL%%/OpenOffice/OODoc/templates/template.sxi
+%%SITE_PERL%%/OpenOffice/OODoc/templates/template.ods
+%%SITE_PERL%%/OpenOffice/OODoc/templates/template.odp
+%%SITE_PERL%%/OpenOffice/OODoc/templates/template.sxc
+%%SITE_PERL%%/OpenOffice/OODoc/templates/template.sxw
+%%SITE_PERL%%/OpenOffice/OODoc/templates/template.odt
+%%SITE_PERL%%/OpenOffice/OODoc/templates/template.sxd
+%%SITE_PERL%%/OpenOffice/OODoc/templates/template.odg
+%%SITE_PERL%%/OpenOffice/OODoc/data/image.png
+bin/oodoc_test
+bin/odfhighlight
+bin/odf_set_title
+bin/odf_set_fields
+bin/odfmetadoc
+bin/odf2pod
+bin/text2table
+bin/odfbuild
+bin/odfsearch
+bin/oodoc_version
+bin/odffilesearch
+bin/text2odf
+bin/odffindbasic
+bin/odfextract
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenOffice/OODoc
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenOffice
+@dirrm %%SITE_PERL%%/OpenOffice/OODoc/data
+@dirrm %%SITE_PERL%%/OpenOffice/OODoc/templates
+@dirrm %%SITE_PERL%%/OpenOffice/OODoc
+@dirrmtry %%SITE_PERL%%/OpenOffice