aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Parse-BooleanLogic/Makefile
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2009-11-24 22:51:07 +0800
committerskreuzer <skreuzer@FreeBSD.org>2009-11-24 22:51:07 +0800
commit303a1fa4322453906b2ef9f3d9a519d7e277d659 (patch)
tree9198a9f68e976874324302300080fa861b7aedf8 /textproc/p5-Parse-BooleanLogic/Makefile
parentad9b04020aa95c3700eed72793e9f49ba97a2c33 (diff)
downloadfreebsd-ports-gnome-303a1fa4322453906b2ef9f3d9a519d7e277d659.tar.gz
freebsd-ports-gnome-303a1fa4322453906b2ef9f3d9a519d7e277d659.tar.zst
freebsd-ports-gnome-303a1fa4322453906b2ef9f3d9a519d7e277d659.zip
Parse::BooleanLogic is a fast parser for boolean expressions. Originally
written for Request Tracker to parse SQL like expressions, it can be used to parse other boolean logic sentences with OPERANDs joined using binary OPERATORs and grouped and nested using parentheses.
Diffstat (limited to 'textproc/p5-Parse-BooleanLogic/Makefile')
-rw-r--r--textproc/p5-Parse-BooleanLogic/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/textproc/p5-Parse-BooleanLogic/Makefile b/textproc/p5-Parse-BooleanLogic/Makefile
new file mode 100644
index 000000000000..53229f1855e9
--- /dev/null
+++ b/textproc/p5-Parse-BooleanLogic/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Parse-BooleanLogic
+# Date created: 2009-11-23
+# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-BooleanLogic
+PORTVERSION= 0.09
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Parser of boolean expressions
+
+BUILD_DEPENDS= p5-Regexp-Common>=2.122:${PORTSDIR}/textproc/p5-Regexp-Common \
+ p5-Module-Install>=0.91_1:${PORTSDIR}/devel/p5-Module-Install
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Parse::BooleanLogic.3
+
+.include <bsd.port.mk>