aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Parse-CSV/Makefile
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-11-01 09:24:23 +0800
committerclsung <clsung@FreeBSD.org>2006-11-01 09:24:23 +0800
commit46b54cad29f1618442b61e03b7494945e8e3bf03 (patch)
tree99065527cbeb4e91ee765df4bf6acc189c00753e /textproc/p5-Parse-CSV/Makefile
parentb3f336de3ae8703eabb84f9350da9e211afa3ec2 (diff)
downloadfreebsd-ports-gnome-46b54cad29f1618442b61e03b7494945e8e3bf03.tar.gz
freebsd-ports-gnome-46b54cad29f1618442b61e03b7494945e8e3bf03.tar.zst
freebsd-ports-gnome-46b54cad29f1618442b61e03b7494945e8e3bf03.zip
Add p5-Parse-CSV 1.00, highly flexible CVS parser for large files.
PR: ports/104559 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Diffstat (limited to 'textproc/p5-Parse-CSV/Makefile')
-rw-r--r--textproc/p5-Parse-CSV/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/textproc/p5-Parse-CSV/Makefile b/textproc/p5-Parse-CSV/Makefile
new file mode 100644
index 000000000000..f945bc40cef5
--- /dev/null
+++ b/textproc/p5-Parse-CSV/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Parse-CSV
+# Date created: 2006-10-19
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-CSV
+PORTVERSION= 1.00
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Parse
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Highly flexible CVS parser for large files
+
+RUN_DEPENDS= p5-Text-CSV_XS>=0.23:${PORTSDIR}/textproc/p5-Text-CSV_XS \
+ p5-Params-Util>=0.17:${PORTSDIR}/devel/p5-Params-Util
+
+PERL_CONFIGURE= yes
+
+MAN3= Parse::CSV.3
+
+.include <bsd.port.mk>