aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-RDF-Simple/Makefile
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-06-15 09:14:50 +0800
committeraaron <aaron@FreeBSD.org>2006-06-15 09:14:50 +0800
commit50fef4bb01c0e6d60056f08dbe0d30eb7efe5358 (patch)
tree07ac25eeef13423892b81cbb485f15c784ebee07 /textproc/p5-RDF-Simple/Makefile
parent146d0f3d3b5da69a3f2fe89b254cd06425aae9ab (diff)
downloadfreebsd-ports-gnome-50fef4bb01c0e6d60056f08dbe0d30eb7efe5358.tar.gz
freebsd-ports-gnome-50fef4bb01c0e6d60056f08dbe0d30eb7efe5358.tar.zst
freebsd-ports-gnome-50fef4bb01c0e6d60056f08dbe0d30eb7efe5358.zip
- Update from v0.13 to v0.3
- Restrict to Perl 5.6+ due to dependencies PR: ports/98331 Submitted by: aaron Approved by: maintainer timeout, tobez (implicit)
Diffstat (limited to 'textproc/p5-RDF-Simple/Makefile')
-rw-r--r--textproc/p5-RDF-Simple/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/textproc/p5-RDF-Simple/Makefile b/textproc/p5-RDF-Simple/Makefile
index 27753f461e24..3c0b6369ae00 100644
--- a/textproc/p5-RDF-Simple/Makefile
+++ b/textproc/p5-RDF-Simple/Makefile
@@ -6,32 +6,32 @@
#
PORTNAME= RDF-Simple
-PORTVERSION= 0.13
-PORTREVISION= 1
+PORTVERSION= 0.30
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= RDF
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-0.3
MAINTAINER= ascope@cpan.org
COMMENT= Read and write RDF without complication
BUILD_DEPENDS= ${SITE_PERL}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX \
- ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
- ${SITE_PERL}/${PERL_ARCH}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker \
- ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3= RDF::Simple.3 RDF::Simple::Parser.3 RDF::Simple::Serialiser.3
+MAN3= RDF::Simple.3 \
+ RDF::Simple::NS.3 \
+ RDF::Simple::Parser.3 \
+ RDF::Simple::Serialiser.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-post-patch:
- @${PERL} -pi -e 's/^our (\S+)/use vars q{$$1};$$1/g' \
- ${WRKSRC}/lib/RDF/Simple.pm ${WRKSRC}/lib/RDF/Simple/*.pm
+.if ${PERL_LEVEL} < 500600 #inherited from security/p5-Authen-SASL
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
.endif
.include <bsd.port.post.mk>