aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-SVG/Makefile
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2002-06-02 21:41:26 +0800
committerskv <skv@FreeBSD.org>2002-06-02 21:41:26 +0800
commit0f851b037bad253b97bc590c7712ee20c39e30c4 (patch)
treea28020abb245d71c28a888fc30481b6e998f363c /textproc/p5-SVG/Makefile
parenta1fc42cb1ab7cb0908bec534aa2e10e35f25069f (diff)
downloadfreebsd-ports-gnome-0f851b037bad253b97bc590c7712ee20c39e30c4.tar.gz
freebsd-ports-gnome-0f851b037bad253b97bc590c7712ee20c39e30c4.tar.zst
freebsd-ports-gnome-0f851b037bad253b97bc590c7712ee20c39e30c4.zip
Updated to 2.1, examples added
Diffstat (limited to 'textproc/p5-SVG/Makefile')
-rw-r--r--textproc/p5-SVG/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/textproc/p5-SVG/Makefile b/textproc/p5-SVG/Makefile
index dbd4214bd404..b7eb75cad98e 100644
--- a/textproc/p5-SVG/Makefile
+++ b/textproc/p5-SVG/Makefile
@@ -6,17 +6,29 @@
#
PORTNAME= SVG
-PORTVERSION= 1.13
+PORTVERSION= 2.1
CATEGORIES= textproc graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= SVG
PKGNAMEPREFIX= p5-
-MAINTAINER= skv@protey.ru
+MAINTAINER= skv@FreeBSD.org
PERL_CONFIGURE= yes
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
-MAN3= SVG.3
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= SVG.3 SVG::DOM.3 SVG::Element.3 SVG::Manual.3 SVG::XML.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-patch:
+ @${FIND} ${WRKSRC} \( -name "*.p[lm]" -or -name "*.cgi" \
+ -or -name "*.pod" \)|xargs ${PERL} -pi -e 's/\x0d//g;'
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>