aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Spreadsheet-WriteExcel/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-08-30 02:26:55 +0800
committerpetef <petef@FreeBSD.org>2001-08-30 02:26:55 +0800
commit634d8603bf8a924eec4e21d6358468bc6977005a (patch)
tree793fc5aab545e2d28297c2f26ad61e7cf0bf0bb6 /textproc/p5-Spreadsheet-WriteExcel/Makefile
parentfef4b048cb6e414027594afc511bbc606d503829 (diff)
downloadfreebsd-ports-gnome-634d8603bf8a924eec4e21d6358468bc6977005a.tar.gz
freebsd-ports-gnome-634d8603bf8a924eec4e21d6358468bc6977005a.tar.zst
freebsd-ports-gnome-634d8603bf8a924eec4e21d6358468bc6977005a.zip
- update to 0.33
- install documentation - install examples in ${PREFIX}/share/examples/Spreadsheet-WriteExcel (instead of inside of ${SITE_PERL}/Spreadsheet/WriteExcel/examples/) - sort pkg-plist PR: 30131 Submitted by: maintainer
Diffstat (limited to 'textproc/p5-Spreadsheet-WriteExcel/Makefile')
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/Makefile29
1 files changed, 22 insertions, 7 deletions
diff --git a/textproc/p5-Spreadsheet-WriteExcel/Makefile b/textproc/p5-Spreadsheet-WriteExcel/Makefile
index bd0849f96883..58053a19fd8e 100644
--- a/textproc/p5-Spreadsheet-WriteExcel/Makefile
+++ b/textproc/p5-Spreadsheet-WriteExcel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Spreadsheet-WriteExcel
-PORTVERSION= 0.31
+PORTVERSION= 0.33
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Spreadsheet
@@ -19,15 +19,30 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3= Spreadsheet::WriteExcel::Worksheet.3 \
+MAN3= Spreadsheet::WriteExcel.3 \
Spreadsheet::WriteExcel::BIFFwriter.3 \
- Spreadsheet::WriteExcel::OLEwriter.3 \
- Spreadsheet::WriteExcel::Workbook.3 \
- Spreadsheet::WriteExcel::examples::WorkbookBig.3 \
- Spreadsheet::WriteExcel.3 \
+ Spreadsheet::WriteExcel::Big.3 \
Spreadsheet::WriteExcel::Format.3 \
Spreadsheet::WriteExcel::Formula.3 \
- Spreadsheet::WriteExcel::examples::Big.3
+ Spreadsheet::WriteExcel::OLEwriter.3 \
+ Spreadsheet::WriteExcel::Workbook.3 \
+ Spreadsheet::WriteExcel::WorkbookBig.3 \
+ Spreadsheet::WriteExcel::Worksheet.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+pre-configure:
+ ${MV} ${WRKSRC}/WriteExcel/doc ${WRKSRC}
+ ${MV} ${WRKSRC}/WriteExcel/examples ${WRKSRC}
+ ${PERL} -pi -e 's:WriteExcel/(doc|examples):\1:g' \
+ ${WRKSRC}/MANIFEST
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+ @${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* \
+ ${PREFIX}/share/examples/${PORTNAME}
+.endif
+
.include <bsd.port.mk>