aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Spreadsheet-WriteExcel
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-02-21 00:33:26 +0800
committersobomax <sobomax@FreeBSD.org>2003-02-21 00:33:26 +0800
commit1e607f868b5505e10fabe70f19c1c6e491e4d1a0 (patch)
tree5a6539846b1be0d7960d421883f382b1984b610b /textproc/p5-Spreadsheet-WriteExcel
parent548c9ae86f72ebe1570fffefb0f5b4dd3f3c0ab1 (diff)
downloadfreebsd-ports-gnome-1e607f868b5505e10fabe70f19c1c6e491e4d1a0.tar.gz
freebsd-ports-gnome-1e607f868b5505e10fabe70f19c1c6e491e4d1a0.tar.zst
freebsd-ports-gnome-1e607f868b5505e10fabe70f19c1c6e491e4d1a0.zip
Conditionalise several dependencies on PERL_LEVEL to make those ports more
friendly for perl-5.8.0, which has those dependencies included into the base distribution. Sponsired by: Porta Software Ltd
Diffstat (limited to 'textproc/p5-Spreadsheet-WriteExcel')
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/textproc/p5-Spreadsheet-WriteExcel/Makefile b/textproc/p5-Spreadsheet-WriteExcel/Makefile
index c79fe848b1d8..4c8ae8dfa51d 100644
--- a/textproc/p5-Spreadsheet-WriteExcel/Makefile
+++ b/textproc/p5-Spreadsheet-WriteExcel/Makefile
@@ -15,7 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/OLE/Storage_Lite.pm:${PORTSDIR}/devel/p5-OLE-Storage_Lite \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip
@@ -37,6 +36,12 @@ MAN3= Spreadsheet::WriteExcel.3 \
Spreadsheet::WriteExcel::Worksheet.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
pre-configure:
@${MV} ${WRKSRC}/WriteExcel/doc ${WRKSRC}
@${MV} ${WRKSRC}/WriteExcel/examples ${WRKSRC}
@@ -55,4 +60,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/examples/*.pl ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>