aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Text-Ngram
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2004-11-04 11:23:33 +0800
committerclsung <clsung@FreeBSD.org>2004-11-04 11:23:33 +0800
commite9291c8008eafdfb0442d059d97087d37f467951 (patch)
tree1bcd76df0ffcbdc410f502dcdccf834c3fd5be7a /textproc/p5-Text-Ngram
parent4f5d9c633ffbff68d5cd3593d3a206b109bc0124 (diff)
downloadfreebsd-ports-gnome-e9291c8008eafdfb0442d059d97087d37f467951.tar.gz
freebsd-ports-gnome-e9291c8008eafdfb0442d059d97087d37f467951.tar.zst
freebsd-ports-gnome-e9291c8008eafdfb0442d059d97087d37f467951.zip
- perl extension, basis for n-gram analysis, which is
XS-based implementation of n-gram spectrum analysis. - currently provide two function: ngram_counts add_to_counts. Approved by: co-mentor (vanilla)
Diffstat (limited to 'textproc/p5-Text-Ngram')
-rw-r--r--textproc/p5-Text-Ngram/Makefile28
-rw-r--r--textproc/p5-Text-Ngram/distinfo2
-rw-r--r--textproc/p5-Text-Ngram/pkg-descr15
-rw-r--r--textproc/p5-Text-Ngram/pkg-plist7
4 files changed, 52 insertions, 0 deletions
diff --git a/textproc/p5-Text-Ngram/Makefile b/textproc/p5-Text-Ngram/Makefile
new file mode 100644
index 000000000000..67634808bc27
--- /dev/null
+++ b/textproc/p5-Text-Ngram/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Text::Ngram
+# Date created: Nov 4 2004
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Ngram
+PORTVERSION= 0.05
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl module for n-gram analysis
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::Ngram.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-Ngram/distinfo b/textproc/p5-Text-Ngram/distinfo
new file mode 100644
index 000000000000..82e412423a43
--- /dev/null
+++ b/textproc/p5-Text-Ngram/distinfo
@@ -0,0 +1,2 @@
+MD5 (Text-Ngram-0.05.tar.gz) = 3a06ea5a46d42103f311b3fdf1303d68
+SIZE (Text-Ngram-0.05.tar.gz) = 9958
diff --git a/textproc/p5-Text-Ngram/pkg-descr b/textproc/p5-Text-Ngram/pkg-descr
new file mode 100644
index 000000000000..3a411edf9a87
--- /dev/null
+++ b/textproc/p5-Text-Ngram/pkg-descr
@@ -0,0 +1,15 @@
+Text-Ngram
+
+n-Gram analysis is a field in textual analysis which uses sliding
+window character sequences in order to aid topic analysis, language
+determination and so on. The n-gram spectrum of a document can be
+used to compare and filter documents in multiple languages, prepare
+word prediction networks, and perform spelling correction.
+
+This module provides an efficient XS-based implementation of n-gram
+spectrum analysis.
+
+WWW: http://search.cpan.org/dist/Text-Ngram/
+
+- Cheng-Lung Sung
+clsung@FreeBSD.org
diff --git a/textproc/p5-Text-Ngram/pkg-plist b/textproc/p5-Text-Ngram/pkg-plist
new file mode 100644
index 000000000000..f240cf4780d2
--- /dev/null
+++ b/textproc/p5-Text-Ngram/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Ngram/Ngram.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Ngram/Ngram.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Ngram/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Ngram.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Ngram
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Text 2>/dev/null || true