aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Text-Template
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2012-04-06 21:34:23 +0800
committerculot <culot@FreeBSD.org>2012-04-06 21:34:23 +0800
commit076f4289b9414683715ee92e1151c35508c9195e (patch)
treef020f8f960d8c45e9951243cf0b40cb8f1ac9d0f /textproc/p5-Text-Template
parent3022acaa53e0906674bddbf783846ba676f3224a (diff)
downloadfreebsd-ports-gnome-076f4289b9414683715ee92e1151c35508c9195e.tar.gz
freebsd-ports-gnome-076f4289b9414683715ee92e1151c35508c9195e.tar.zst
freebsd-ports-gnome-076f4289b9414683715ee92e1151c35508c9195e.zip
- Add a patch to fix a memory leak [1]
- Bump PORTREVISION [1] - Add LICENSE (Artistic 1 & GPL 2) PR: ports/166198 [1] Submitted by: Zane C.B-H. <vvelox@vvelox.net> Feature safe: yes
Diffstat (limited to 'textproc/p5-Text-Template')
-rw-r--r--textproc/p5-Text-Template/Makefile7
-rw-r--r--textproc/p5-Text-Template/files/patch-lib_Text_Template.pm10
2 files changed, 17 insertions, 0 deletions
diff --git a/textproc/p5-Text-Template/Makefile b/textproc/p5-Text-Template/Makefile
index f68920b3224e..aa15d903e07e 100644
--- a/textproc/p5-Text-Template/Makefile
+++ b/textproc/p5-Text-Template/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Text-Template
PORTVERSION= 1.45
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= http://perl.plover.com/Template/ \
CPAN
@@ -15,8 +16,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Expand template text with embedded Perl
+LICENSE= ART10 GPLv2
+LICENSE_COMB= dual
+
PERL_CONFIGURE= YES
MAN3= Text::Template.3 Text::Template::Preprocess.3
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.orig" -delete
+
.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Template/files/patch-lib_Text_Template.pm b/textproc/p5-Text-Template/files/patch-lib_Text_Template.pm
new file mode 100644
index 000000000000..890a01d0a59e
--- /dev/null
+++ b/textproc/p5-Text-Template/files/patch-lib_Text_Template.pm
@@ -0,0 +1,10 @@
+--- lib/Text/Template.pm.orig 2008-04-16 18:38:08.000000000 -0500
++++ lib/Text/Template.pm 2012-03-17 06:44:14.882739137 -0500
+@@ -428,6 +428,8 @@
+ foreach my $key (keys %$hash) {
+ undef $hash->{$key};
+ }
++ %$hash = ();
++ delete $Text::Template::{$s."::"};
+ }
+ }