aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Text-Xslate
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2010-06-10 16:14:17 +0800
committertobez <tobez@FreeBSD.org>2010-06-10 16:14:17 +0800
commit6bf7660b8ea54f804552ca07a1cb7af43b3c8e25 (patch)
tree84e4a88c44a0de0e1d38081997fbbdcc16a59f64 /textproc/p5-Text-Xslate
parent6990e7d38be01231f59bf243485eb274b0bce9b1 (diff)
downloadfreebsd-ports-gnome-6bf7660b8ea54f804552ca07a1cb7af43b3c8e25.tar.gz
freebsd-ports-gnome-6bf7660b8ea54f804552ca07a1cb7af43b3c8e25.tar.zst
freebsd-ports-gnome-6bf7660b8ea54f804552ca07a1cb7af43b3c8e25.zip
Add textproc/p5-Text-Xslate 0.1031, a high performance template engine
for Perl.
Diffstat (limited to 'textproc/p5-Text-Xslate')
-rw-r--r--textproc/p5-Text-Xslate/Makefile50
-rw-r--r--textproc/p5-Text-Xslate/distinfo3
-rw-r--r--textproc/p5-Text-Xslate/pkg-descr6
-rw-r--r--textproc/p5-Text-Xslate/pkg-plist32
4 files changed, 91 insertions, 0 deletions
diff --git a/textproc/p5-Text-Xslate/Makefile b/textproc/p5-Text-Xslate/Makefile
new file mode 100644
index 000000000000..9d758cca9c51
--- /dev/null
+++ b/textproc/p5-Text-Xslate/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: textproc/p5-Text-Xslate
+# Date created: 10 June 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Xslate
+PORTVERSION= 0.1031
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= High performance template engine
+
+BUILD_DEPENDS= p5-parent>=0.221:${PORTSDIR}/devel/p5-parent \
+ p5-Mouse>=0.55:${PORTSDIR}/devel/p5-Mouse \
+ p5-Any-Moose>=0.13:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-MouseX-Getopt>=0.2601:${PORTSDIR}/devel/p5-MouseX-Getopt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires
+
+PERL_CONFIGURE= yes
+
+MAN1= xslate.1
+MAN3= Text::Xslate.3 \
+ Text::Xslate::Bridge.3 \
+ Text::Xslate::Compiler.3 \
+ Text::Xslate::EscapedString.3 \
+ Text::Xslate::PP.3 \
+ Text::Xslate::PP::Booster.3 \
+ Text::Xslate::PP::Const.3 \
+ Text::Xslate::PP::EscapedString.3 \
+ Text::Xslate::PP::Macro.3 \
+ Text::Xslate::PP::Method.3 \
+ Text::Xslate::PP::Opcode.3 \
+ Text::Xslate::PP::State.3 \
+ Text::Xslate::PP::Type::Array.3 \
+ Text::Xslate::PP::Type::Hash.3 \
+ Text::Xslate::PP::Type::Pair.3 \
+ Text::Xslate::Parser.3 \
+ Text::Xslate::Symbol.3 \
+ Text::Xslate::Syntax::Kolon.3 \
+ Text::Xslate::Syntax::Metakolon.3 \
+ Text::Xslate::Syntax::TTerse.3 \
+ Text::Xslate::Util.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Xslate/distinfo b/textproc/p5-Text-Xslate/distinfo
new file mode 100644
index 000000000000..21a3006251b4
--- /dev/null
+++ b/textproc/p5-Text-Xslate/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-Xslate-0.1031.tar.gz) = aa2d41156c7c7c31ca3b4e5fd08bd4c0
+SHA256 (Text-Xslate-0.1031.tar.gz) = 998652385b8b466916b5e512222204358a020abd5f36fabf3d27718658ab877f
+SIZE (Text-Xslate-0.1031.tar.gz) = 132189
diff --git a/textproc/p5-Text-Xslate/pkg-descr b/textproc/p5-Text-Xslate/pkg-descr
new file mode 100644
index 000000000000..bde478bcd2f8
--- /dev/null
+++ b/textproc/p5-Text-Xslate/pkg-descr
@@ -0,0 +1,6 @@
+Text::Xslate is a template engine tuned for persistent applications.
+This engine introduces the virtual machine paradigm. That is, templates
+are compiled into xslate intermediate code, and then executed by the
+xslate virtual machine.
+
+WWW: http://search.cpan.org/dist/Text-Xslate/
diff --git a/textproc/p5-Text-Xslate/pkg-plist b/textproc/p5-Text-Xslate/pkg-plist
new file mode 100644
index 000000000000..788b1a071015
--- /dev/null
+++ b/textproc/p5-Text-Xslate/pkg-plist
@@ -0,0 +1,32 @@
+bin/xslate
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/Bridge.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/Compiler.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/EscapedString.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP/Booster.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP/Const.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP/EscapedString.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP/Macro.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP/Method.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP/Opcode.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP/State.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP/Type/Array.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP/Type/Hash.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP/Type/Pair.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/Parser.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/Symbol.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/Syntax/Kolon.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/Syntax/Metakolon.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/Syntax/TTerse.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Xslate/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Xslate/Xslate.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Xslate/Xslate.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP/Type
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/Syntax
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Xslate
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate/PP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Text/Xslate
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Text