aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Unicode-Unihan/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2006-11-15 16:16:40 +0800
committerleeym <leeym@FreeBSD.org>2006-11-15 16:16:40 +0800
commitb8923fa3e199cf129a5fba056e9c0d883a994107 (patch)
treea43013801cb4232da46409e496e21fa9f7c9174d /textproc/p5-Unicode-Unihan/Makefile
parent05aa6564ae20a2e65b4a871676a2948126a41b25 (diff)
downloadfreebsd-ports-gnome-b8923fa3e199cf129a5fba056e9c0d883a994107.tar.gz
freebsd-ports-gnome-b8923fa3e199cf129a5fba056e9c0d883a994107.tar.zst
freebsd-ports-gnome-b8923fa3e199cf129a5fba056e9c0d883a994107.zip
- Add p5-Unicode-Unihan-0.02
Unicode::Unihan - The Unihan Data Base 3.2.0 use Unicode::Unihan; my $db = new Unicode::Unihan; print join("," => $db->Mandarin("\x{5c0f}\x{98fc}\x{5f3e}"), "\n"; This module provides a user-friendly interface to the Unicode Unihan Database 3.2. With this module, the Unihan database is as easy as shown in above. WWW: http://search.cpan.org/dist/Unicode-Unihan/
Diffstat (limited to 'textproc/p5-Unicode-Unihan/Makefile')
-rw-r--r--textproc/p5-Unicode-Unihan/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-Unicode-Unihan/Makefile b/textproc/p5-Unicode-Unihan/Makefile
new file mode 100644
index 000000000000..8d89d2fc24a6
--- /dev/null
+++ b/textproc/p5-Unicode-Unihan/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Unicode-Unihan
+# Date created: 15 November 2006
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Unicode-Unihan
+DISTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/D/DA/DANKOGAI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= The Unihan Data Base 3.2.0
+
+PERL_CONFIGURE= yes
+
+MAN3= Unicode::Unihan.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>