aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-XML-Atom-Syndication/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2006-04-21 10:00:27 +0800
committerleeym <leeym@FreeBSD.org>2006-04-21 10:00:27 +0800
commit00431a1e017f47985a4d2d0c433897da8c90b4fd (patch)
treeac170c3b4a7a0cc096d06821245c58119ced909a /textproc/p5-XML-Atom-Syndication/Makefile
parent9e71e342676dda8b25567846b06c917962fd31d3 (diff)
downloadfreebsd-ports-gnome-00431a1e017f47985a4d2d0c433897da8c90b4fd.tar.gz
freebsd-ports-gnome-00431a1e017f47985a4d2d0c433897da8c90b4fd.tar.zst
freebsd-ports-gnome-00431a1e017f47985a4d2d0c433897da8c90b4fd.zip
- update to 0.901
- assign to perl@
Diffstat (limited to 'textproc/p5-XML-Atom-Syndication/Makefile')
-rw-r--r--textproc/p5-XML-Atom-Syndication/Makefile29
1 files changed, 20 insertions, 9 deletions
diff --git a/textproc/p5-XML-Atom-Syndication/Makefile b/textproc/p5-XML-Atom-Syndication/Makefile
index e4b4d11e6488..d093bd26f226 100644
--- a/textproc/p5-XML-Atom-Syndication/Makefile
+++ b/textproc/p5-XML-Atom-Syndication/Makefile
@@ -5,24 +5,35 @@
# $FreeBSD$
PORTNAME= XML-Atom-Syndication
-PORTVERSION= 0.091
+PORTVERSION= 0.901
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Simple lightweight client for consuming Atom syndication feeds
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/Class/XPath.pm:${PORTSDIR}/devel/p5-Class-XPath \
- ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/XML/Parser/Style/Elemental.pm:${PORTSDIR}/textproc/p5-XML-Parser-Style-Elemental
+RUN_DEPENDS= ${SITE_PERL}/XML/Elemental.pm:${PORTSDIR}/textproc/p5-XML-Elemental \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/Class/ErrorHandler.pm:${PORTSDIR}/devel/p5-Class-ErrorHandler \
+ ${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PERL_CONFIGURE= yes
-MAN3= XML::Atom::Syndication.3 XML::Atom::Syndication::Element.3 \
- XML::Atom::Syndication::Document.3 \
- XML::Atom::Syndication::Characters.3
+MAN3= XML::Atom::Syndication.3 \
+ XML::Atom::Syndication::Category.3 \
+ XML::Atom::Syndication::Content.3 \
+ XML::Atom::Syndication::Entry.3 \
+ XML::Atom::Syndication::Feed.3 \
+ XML::Atom::Syndication::Generator.3 \
+ XML::Atom::Syndication::Link.3 \
+ XML::Atom::Syndication::Object.3 \
+ XML::Atom::Syndication::Person.3 \
+ XML::Atom::Syndication::Source.3 \
+ XML::Atom::Syndication::Text.3 \
+ XML::Atom::Syndication::Writer.3 \
.include <bsd.port.mk>