aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-XML-DT/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-04 08:00:06 +0800
committerwill <will@FreeBSD.org>2001-01-04 08:00:06 +0800
commita882e7d1e6c7a435821f7982f931a5e9510e7573 (patch)
tree321583ca58c1c9edada7b445ddc974656d9b8b6e /textproc/p5-XML-DT/Makefile
parentbcc75728901f0b26e4030ff722f6036728170135 (diff)
downloadfreebsd-ports-gnome-a882e7d1e6c7a435821f7982f931a5e9510e7573.tar.gz
freebsd-ports-gnome-a882e7d1e6c7a435821f7982f931a5e9510e7573.tar.zst
freebsd-ports-gnome-a882e7d1e6c7a435821f7982f931a5e9510e7573.zip
Add p5-XML-DT 0.19, a perl module for down translation of XML to strings.
PR: 23994 Submitted by: Anton Berezin <tobez@tobez.org>
Diffstat (limited to 'textproc/p5-XML-DT/Makefile')
-rw-r--r--textproc/p5-XML-DT/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/p5-XML-DT/Makefile b/textproc/p5-XML-DT/Makefile
new file mode 100644
index 000000000000..9619d841cfef
--- /dev/null
+++ b/textproc/p5-XML-DT/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: textproc/p5-XML-DT
+# Date created: 01 January 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-DT
+PORTVERSION= 0.19
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= XML::DT.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-install:
+ @${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/XML/DT/examples
+ @${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/XML/DT/examples/XPath
+ @${INSTALL_DATA} ${WRKSRC}/examples/XPath/* ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/XML/DT/examples/XPath
+ @${INSTALL_DATA} `ls -d ${WRKSRC}/examples/* | ${GREP} -v XPath` ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/XML/DT/examples
+
+.include <bsd.port.mk>