aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-XML-Feed/Makefile
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2005-07-31 19:06:54 +0800
committerlth <lth@FreeBSD.org>2005-07-31 19:06:54 +0800
commit558f187836e8aa308711599f3ffce84977f6a82c (patch)
tree7335b2576101bd6c7156e55a04a3265505c97fe9 /textproc/p5-XML-Feed/Makefile
parent374cb45cf3503a5db928da529b8e91bd41406fba (diff)
downloadfreebsd-ports-gnome-558f187836e8aa308711599f3ffce84977f6a82c.tar.gz
freebsd-ports-gnome-558f187836e8aa308711599f3ffce84977f6a82c.tar.zst
freebsd-ports-gnome-558f187836e8aa308711599f3ffce84977f6a82c.zip
Update to 0.05
Diffstat (limited to 'textproc/p5-XML-Feed/Makefile')
-rw-r--r--textproc/p5-XML-Feed/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/textproc/p5-XML-Feed/Makefile b/textproc/p5-XML-Feed/Makefile
index 28a63103fbfc..1203f080adf6 100644
--- a/textproc/p5-XML-Feed/Makefile
+++ b/textproc/p5-XML-Feed/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= XML-Feed
-PORTVERSION= 0.02
+PORTVERSION= 0.05
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
@@ -23,7 +23,10 @@ BUILD_DEPENDS= ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS \
${SITE_PERL}/DateTime/Format/Mail.pm:${PORTSDIR}/devel/p5-DateTime-Format-Mail \
${SITE_PERL}/DateTime/Format/W3CDTF.pm:${PORTSDIR}/devel/p5-DateTime-Format-W3CDTF \
${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/Class/ErrorHandler.pm:${PORTSDIR}/devel/p5-Class-ErrorHandler \
+ ${SITE_PERL}/Feed/Find.pm:${PORTSDIR}/www/p5-Feed-Find \
+ ${SITE_PERL}/URI/Fetch.pm:${PORTSDIR}/www/p5-URI-Fetch
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
@@ -32,6 +35,9 @@ MAN3= XML::Feed.3 \
XML::Feed::Content.3 \
XML::Feed::Entry.3
+post-patch:
+ ${PERL} -pi -e '$$_ = "" if m|auto_install|' ${WRKSRC}/Makefile.PL
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500601