aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/pcrs
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-08-15 19:27:16 +0800
committerdanfe <danfe@FreeBSD.org>2013-08-15 19:27:16 +0800
commitbb34a080ac4284074756f50ca4acd3babc48815f (patch)
treea6e034c62e7f1e612e45628a0a466100b5f1187a /textproc/pcrs
parentae4ef166ab393c71037f05007d60a9922ddc8884 (diff)
downloadfreebsd-ports-gnome-bb34a080ac4284074756f50ca4acd3babc48815f.tar.gz
freebsd-ports-gnome-bb34a080ac4284074756f50ca4acd3babc48815f.tar.zst
freebsd-ports-gnome-bb34a080ac4284074756f50ca4acd3babc48815f.zip
- Try to unbreak parallel builds (-jX) by adding missing dependencies
for static library target - Unbreak configure script against Clang's cpp(1): suppress harmless warning that was treated as an error (=> missing pcre.h) - While here, trim Makefile header, remove defunct mirrors from the MASTER_SITES, convert LIB_DEPENDS and USE_GMAKE, kill spaces at EOL of port description, define LICENSE (LGPL21) Reported by: marino Approved by: miwi, bapt (portmgr, implicit)
Diffstat (limited to 'textproc/pcrs')
-rw-r--r--textproc/pcrs/Makefile21
-rw-r--r--textproc/pcrs/files/patch-Makefile.in3
-rw-r--r--textproc/pcrs/files/patch-configure9
-rw-r--r--textproc/pcrs/pkg-descr6
4 files changed, 22 insertions, 17 deletions
diff --git a/textproc/pcrs/Makefile b/textproc/pcrs/Makefile
index c350571ca720..ad07005d3647 100644
--- a/textproc/pcrs/Makefile
+++ b/textproc/pcrs/Makefile
@@ -1,31 +1,26 @@
-# New ports collection makefile for: pcrs
-# Date created: 31 July 2005
-# Whom: Ken Wong <wongk@apt.homeunix.net>
-#
+# Created by: Ken Wong <wongk@apt.homeunix.net>
# $FreeBSD$
-#
PORTNAME= pcrs
PORTVERSION= 0.0.3
PORTREVISION= 2
CATEGORIES= textproc
-MASTER_SITES= http://distfiles.master.finkmirrors.net/\
- http://download.mirror.ac.uk/mirror/master.us.finkmirrors.net/distfiles/\
- http://mirror.phy.olemiss.edu/mirror/fink/distfiles/
+MASTER_SITES= http://distfiles.master.finkmirrors.net/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= wongk@apt.homeunix.net
-COMMENT= Perl compatible regular expression based substitutions
+COMMENT= Perl-compatible regular expression based substitutions
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+LICENSE= LGPL21
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+USES= gmake
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-
USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
MAN3= pcrs.3
PLIST_FILES= bin/pcrsed \
lib/libpcrs.a \
diff --git a/textproc/pcrs/files/patch-Makefile.in b/textproc/pcrs/files/patch-Makefile.in
index d8a754e85e49..c1a72e1a4734 100644
--- a/textproc/pcrs/files/patch-Makefile.in
+++ b/textproc/pcrs/files/patch-Makefile.in
@@ -23,7 +23,8 @@
- $(CC) $(CLFLAGS) $(LDFLAGS) $(LIBFLAGS) -Wl,-soname,libpcrs.so.$(VERSION_MAJOR) -o libpcrs.so.$(VERSION) pcrs.@OBJEXT@ $(LIBS)
+ $(CC) $(CFLAGS) $(LDFLAGS) $(LIBFLAGS) -Wl,-soname,libpcrs.so.$(VERSION_MAJOR) -o libpcrs.so.$(VERSION_MAJOR) pcrs.@OBJEXT@ $(LIBS)
- static:
+-static:
++static: pcrs.@OBJEXT@
$(AR) libpcrs.a pcrs.@OBJEXT@
install: all
diff --git a/textproc/pcrs/files/patch-configure b/textproc/pcrs/files/patch-configure
index 3a82a058d29e..aa833da51366 100644
--- a/textproc/pcrs/files/patch-configure
+++ b/textproc/pcrs/files/patch-configure
@@ -38,3 +38,12 @@
cross_compiling=$ac_cv_prog_cc_cross
echo "$ac_t""$ac_cv_prog_cc_works" 1>&6
+@@ -1256,7 +1256,7 @@
+ EOF
+ ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+ { (eval echo configure:1259: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+-ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
++ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$" | grep -v warning:`
+ if test -z "$ac_err"; then
+ rm -rf conftest*
+ eval "ac_cv_header_$ac_safe=yes"
diff --git a/textproc/pcrs/pkg-descr b/textproc/pcrs/pkg-descr
index a4a5c48a57ac..1c6eee5e79d0 100644
--- a/textproc/pcrs/pkg-descr
+++ b/textproc/pcrs/pkg-descr
@@ -1,3 +1,3 @@
-PCRS is a small library, written as a supplement to the PCRE library,
-that implements regex based substitution with the syntax and semantics
-of Perl's s/// operator.
+PCRS is a small library, written as a supplement to the PCRE library,
+that implements regex based substitution with the syntax and semantics
+of Perl's s/// operator.