aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/pugixml
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-06-24 22:54:30 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-06-24 22:54:30 +0800
commit4309f6e49c4399a4d04159a2ddf9681961c3de59 (patch)
treea099ba85d1f40df7c312b50ebc5b939cb248c43b /textproc/pugixml
parentad94a4b70ad03a7ed110720750612d2da18d2783 (diff)
downloadfreebsd-ports-gnome-4309f6e49c4399a4d04159a2ddf9681961c3de59.tar.gz
freebsd-ports-gnome-4309f6e49c4399a4d04159a2ddf9681961c3de59.tar.zst
freebsd-ports-gnome-4309f6e49c4399a4d04159a2ddf9681961c3de59.zip
- Update to 1.7
PR: 210006 Submitted by: ybungalobill@gmail.com (maintainer)
Diffstat (limited to 'textproc/pugixml')
-rw-r--r--textproc/pugixml/Makefile3
-rw-r--r--textproc/pugixml/distinfo4
-rw-r--r--textproc/pugixml/files/patch-scripts_CMakeLists.txt22
-rw-r--r--textproc/pugixml/pkg-plist2
4 files changed, 19 insertions, 12 deletions
diff --git a/textproc/pugixml/Makefile b/textproc/pugixml/Makefile
index f205edf5f28f..bab2c0355756 100644
--- a/textproc/pugixml/Makefile
+++ b/textproc/pugixml/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= pugixml
-PORTVERSION= 1.6
-PORTREVISION= 1
+PORTVERSION= 1.7
CATEGORIES= textproc
MASTER_SITES= http://github.com/zeux/pugixml/releases/download/v${PORTVERSION}/
diff --git a/textproc/pugixml/distinfo b/textproc/pugixml/distinfo
index be3ad6cc0668..3eb22d46d8f5 100644
--- a/textproc/pugixml/distinfo
+++ b/textproc/pugixml/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pugixml-1.6.tar.gz) = 473705c496d45ee6a74f73622b175dfb5dde0de372c4dc61a5acb964516cd9de
-SIZE (pugixml-1.6.tar.gz) = 346616
+SHA256 (pugixml-1.7.tar.gz) = fbe10d46f61d769f7d92a296102e4e2bd3ee16130f11c5b10a1aae590ea1f5ca
+SIZE (pugixml-1.7.tar.gz) = 354472
diff --git a/textproc/pugixml/files/patch-scripts_CMakeLists.txt b/textproc/pugixml/files/patch-scripts_CMakeLists.txt
index 9d1f7d2a3db7..e91febe1245f 100644
--- a/textproc/pugixml/files/patch-scripts_CMakeLists.txt
+++ b/textproc/pugixml/files/patch-scripts_CMakeLists.txt
@@ -1,18 +1,23 @@
---- scripts/CMakeLists.txt.orig 2015-03-25 03:19:09 UTC
-+++ scripts/CMakeLists.txt
-@@ -16,19 +16,16 @@ if(DEFINED BUILD_DEFINES)
- add_definitions(${BUILD_DEFINES})
+--- scripts/CMakeLists.txt.orig 2015-10-19 06:15:50.000000000 +0300
++++ scripts/CMakeLists.txt 2016-06-20 22:08:33.133152000 +0300
+@@ -19,27 +19,19 @@
+ endforeach()
endif()
-if(BUILD_SHARED_LIBS)
-- add_library(pugixml SHARED ${SOURCES})
+- add_library(pugixml SHARED ${SOURCES})
-else()
-- add_library(pugixml STATIC ${SOURCES})
+- add_library(pugixml STATIC ${SOURCES})
+-endif()
+-
+-# Enable C++11 long long for compilers that are capable of it
+-if(NOT ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} STRLESS 3.1)
+- target_compile_features(pugixml PUBLIC cxx_long_long_type)
-endif()
+add_library(pugixml SHARED ${SOURCES})
+add_library(pugixml_static STATIC ${SOURCES})
- set_target_properties(pugixml PROPERTIES VERSION 1.6 SOVERSION 1)
+ set_target_properties(pugixml PROPERTIES VERSION 1.7 SOVERSION 1)
+set_target_properties(pugixml_static PROPERTIES OUTPUT_NAME pugixml)
-install(TARGETS pugixml EXPORT pugixml-config
@@ -24,3 +29,6 @@
install(FILES ${HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
-install(EXPORT pugixml-config DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/pugixml)
+
+ if(BUILD_TESTS)
+ file(GLOB TEST_SOURCES ../tests/*.cpp)
diff --git a/textproc/pugixml/pkg-plist b/textproc/pugixml/pkg-plist
index 0e0cfa9d452d..3e8afd9c2473 100644
--- a/textproc/pugixml/pkg-plist
+++ b/textproc/pugixml/pkg-plist
@@ -3,4 +3,4 @@ include/pugixml.hpp
lib/libpugixml.a
lib/libpugixml.so
lib/libpugixml.so.1
-lib/libpugixml.so.1.6
+lib/libpugixml.so.1.7