aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/pugixml
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2017-01-27 04:16:33 +0800
committerriggs <riggs@FreeBSD.org>2017-01-27 04:16:33 +0800
commit83d7627295801a046498c680d277b1664d4875fc (patch)
treeef11a7377a71230392e7844a09bae5fef26d4a2d /textproc/pugixml
parent945cbf03aeb527975dd7be6487853bd87febf7eb (diff)
downloadfreebsd-ports-gnome-83d7627295801a046498c680d277b1664d4875fc.tar.gz
freebsd-ports-gnome-83d7627295801a046498c680d277b1664d4875fc.tar.zst
freebsd-ports-gnome-83d7627295801a046498c680d277b1664d4875fc.zip
Enable c++11 support: Fix dependent ports which require c++11 or later
PR: 216468 Submitted by: riggs Approved by: ybungalobill@gmail.com (maintainer) MFH: 2017Q1
Diffstat (limited to 'textproc/pugixml')
-rw-r--r--textproc/pugixml/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/textproc/pugixml/Makefile b/textproc/pugixml/Makefile
index 78663ac29bf4..10c999c5c349 100644
--- a/textproc/pugixml/Makefile
+++ b/textproc/pugixml/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pugixml
PORTVERSION= 1.7
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= https://github.com/zeux/pugixml/releases/download/v${PORTVERSION}/
@@ -10,7 +11,9 @@ COMMENT= Light-weight, simple and fast XML parser for C++ with XPath support
LICENSE= MIT
-USES= cmake
+USES= cmake compiler:c++11-lang
CMAKE_SOURCE_PATH= ${WRKSRC}/scripts
+CXXFLAGS+= -std=c++11
+
.include <bsd.port.mk>