aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-HyperText/Makefile
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2000-10-04 05:35:45 +0800
committernectar <nectar@FreeBSD.org>2000-10-04 05:35:45 +0800
commit4eeea66c8c6acb44dc2fd20746fc981575eb8ba0 (patch)
treeb16dad687239ad072b688a876fa751c4a69bb513 /textproc/py-HyperText/Makefile
parentaf32bc66db182cae1754b160620289841de613d6 (diff)
downloadfreebsd-ports-gnome-4eeea66c8c6acb44dc2fd20746fc981575eb8ba0.tar.gz
freebsd-ports-gnome-4eeea66c8c6acb44dc2fd20746fc981575eb8ba0.tar.zst
freebsd-ports-gnome-4eeea66c8c6acb44dc2fd20746fc981575eb8ba0.zip
Lightweight HTML/XHTML generator for Python
Diffstat (limited to 'textproc/py-HyperText/Makefile')
-rw-r--r--textproc/py-HyperText/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/textproc/py-HyperText/Makefile b/textproc/py-HyperText/Makefile
new file mode 100644
index 000000000000..d618301b053c
--- /dev/null
+++ b/textproc/py-HyperText/Makefile
@@ -0,0 +1,36 @@
+# Ports collection Makefile for: HyperText
+# Date created: 10/03/2000
+# Whom: nectar@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= HyperText
+PORTVERSION= 1.0.1
+CATEGORIES= textproc python
+MASTER_SITES= http://dustman.net/andy/python/HyperText/1.0.1/
+PKGNAMEPREFIX= py-
+
+MAINTAINER= nectar@FreeBSD.org
+
+USE_PYTHON= yes
+WRKSRC= ${WRKDIR}/HyperText
+
+# get rid of pre-compiled stuff: it may not work for the installed
+# version of Python
+post-extract:
+ @cd ${WRKSRC} && ${RM} -f *.py[co]
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ ${MKDIR} ${PYTHON_SITELIBDIR}/HyperText
+ ${CHOWN} ${BINOWN}:${BINGRP} ${PYTHON_SITELIBDIR}/HyperText
+ ${CHMOD} ${BINMODE} ${PYTHON_SITELIBDIR}/HyperText
+ @(set -e -x; cd ${WRKSRC}; for f in *.py *.py[co]; do \
+ ${INSTALL_DATA} $$f ${PYTHON_SITELIBDIR}/HyperText/$$f; \
+ done)
+
+.include <bsd.port.mk>