aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-csv/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2001-03-15 07:47:29 +0800
committervanilla <vanilla@FreeBSD.org>2001-03-15 07:47:29 +0800
commitd89ab9047e1450843b3d9e5f805751692fac7c13 (patch)
tree19b02578e92f8575e38a094f7639cc5d9944bb60 /textproc/py-csv/Makefile
parentb1c8009964d62ff0a137f1f8199850299a3dc286 (diff)
downloadfreebsd-ports-gnome-d89ab9047e1450843b3d9e5f805751692fac7c13.tar.gz
freebsd-ports-gnome-d89ab9047e1450843b3d9e5f805751692fac7c13.tar.zst
freebsd-ports-gnome-d89ab9047e1450843b3d9e5f805751692fac7c13.zip
a small yet fast Python extension module (written
in C) to parse or generate comma-separated value (CSV) files. PR: ports/25408 Submitted by: Johann Visagie <johann@egenetics.com>
Diffstat (limited to 'textproc/py-csv/Makefile')
-rw-r--r--textproc/py-csv/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/textproc/py-csv/Makefile b/textproc/py-csv/Makefile
new file mode 100644
index 000000000000..8eeabef1bd27
--- /dev/null
+++ b/textproc/py-csv/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-csv
+# Date created: 27 February 2001
+# Whom: Johann Visagie <johann@egenetics.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= csv
+PORTVERSION= 0.2
+CATEGORIES= textproc python
+MASTER_SITES= http://object-craft.com.au/projects/csv/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= johann@egenetics.com
+
+USE_PYTHON= yes
+
+WRKSRC= ${WRKDIR}/csv
+
+do-configure:
+ @ (cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${MAKE} -f \
+ Makefile.pre.in boot)
+
+.include <bsd.port.mk>
BSD (2.8.1 to be exact).marcus2004-11-0821-1342/+333 * Fix Palm conduit build with GCC 3.4.2.marcus2004-08-071-0/+34 * Fix build with gcc 3.4.adamw2004-08-033-0/+42 * Fix build on gcc 3.4 a bit. The port still doesn't build,adamw2004-08-031-0/+11 * Use the new GConf handling policy, this will be required for GNOME 2.7/2.8 ormezz2004-07-081-136/+12 * Fix build on amd64 by adding --with-pic to CONFIGURE_ARGS.marcus2004-06-041-0/+4 * Remove a zero-length file that slipped through my cvs rm -f net.marcus2004-05-041-0/+0 * Garbage collect some patches that are no longer needed.marcus2004-05-042-22/+0 * Chase the glib20 update, and bump all affected ports' PORTREVISIONs.marcus2004-04-051-0/+1 * Add intlhack to fix the build on 4.X.marcus2004-03-131-1/+1 * * Update to 1.4.6marcus2004-03-127-58/+53 * Enable support for Kerberos by default. Note: I'm not bumping PORTREVISIONmarcus2004-02-242-7/+17 * Use the new gtkhtml3 component as well as USE_OPENLDAP.marcus2004-02-081-4/+2 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-041-0/+1 * Fix build on amd64.marcus2003-12-192-0/+22 * Fix a bug where Evo would crash on exit on Sparc64. I'm not bumpingmarcus2003-10-261-0/+20 * Update to 1.4.5. Seemarcus2003-09-253-104/+106 * Fix broken db3 configure on -CURRENT. -pthread -> ${PTHREAD_LIBS}bland2003-09-071-0/+1 * Fix a problem where the timezone would reset to UTC when switching views.marcus2003-08-282-0/+107 * Depend on openldap*-client to fix the build and INDEX builds.marcus2003-08-151-1/+1 * Update to 1.4.4. See the release notes for what has changed.marcus2003-08-023-2/+3 * Update to 1.4.3.adamw2003-07-114-17/+6 * Chase libgtkhtml3, and remove the dependency upon soap, whichadamw2003-07-111-3/+2 * Remove the quotes from ${EVO_VERSION} and change the chmod call a bit.marcus2003-06-161-2/+2 * There's no need for a pkg-install script. The work can be done with amarcus2003-06-162-20/+2 * Remove some left over directories.marcus2003-06-161-0/+3 * Patch the correct file to enable the right desktop links.marcus2003-06-142-13/+13 * Fix a problem where new accounts were being created with read-only mailboxes.marcus2003-06-132-2/+27 * The Evolution developers forgot to change the name of the binary in themarcus2003-06-111-0/+13 * Update to 1.4.0. Note, this is now a GNOME 2 application.marcus2003-06-1114-1676/+1463 * Chase the location of the NSS header files.marcus2003-04-131-1/+1 * * Update to 1.2.4marcus2003-04-053-4/+4 * * Update to 1.2.3marcus2003-04-045-95/+29 * * Fix PGP key validation with certain mailers (notably mutt) [1]marcus2003-02-273-1/+86 * Point dependencies on net/openldap2 to net/openldap20edwin2003-02-241-1/+1 * Update to 1.2.2.marcus2003-02-083-3/+3 * Remove the sbin directory.marcus2003-02-021-0/+1 * Update to 1.2.1.marcus2003-01-203-4/+23 * Remove share/gnome/html.marcus2003-01-131-0/+1 * Remove share/gnome/libical-evolution.marcus2003-01-131-0/+1 * Don't statically link the Pilot conduits. This fixes a problem wheremarcus2002-12-253-1/+23 * Add a RUN_DEPENDS on gnomecontrolcenter. This will allow GNOME 2 usersmarcus2002-12-141-2/+3 * Add the FreeBSD GNOME Project News RDF link to the My Evolution news feedsmarcus2002-11-242-7/+8 * Make soup optional in gtkhtml. In doing this, we have to make sure soup ismarcus2002-11-231-1/+2 * Commit the patch that fixes SSL support...ugh.marcus2002-11-121-6/+19 * Fix SSL support.marcus2002-11-121-0/+1 * Update to 1.2.0. This is a big release, and I don't want to polute themarcus2002-11-1222-303/+319 * GNOME has just changed the layout of their FTP site. This resulted inmarcus2002-09-211-1/+1 * Convert all core GNOME1 components and some of the most popular GNOME1sobomax2002-07-121-0/+2 * Add missed gal and gtkhtml into USE_GNOME. Also remove redundant gnomecc fromsobomax2002-07-111-2/+1 * * Update to 1.0.8.marcus2002-07-103-14/+43 * Update to 1.0.7.marcus2002-06-153-2/+5 * The distfile was rerolled on the official MASTER_SITES; no changes.kris2002-05-161-1/+1 * Revert the mast site back to GNOME so that my people page isn't used asmarcus2002-05-141-2/+1 * Update to 1.0.5.marcus2002-05-128-94/+112 * Fix the receive timestamp when DST is in effect. Bump PORTREVISION.marcus2002-05-092-0/+12 * Update to 1.0.4. Use home-rolled distfile (using sources checked out fromsobomax2002-05-089-183/+93 * Fix a problem were date stamps were offset by one hour when DST was in effect.marcus2002-04-272-0/+14 * Since MASTER_SITE_LOCAL distribution mechanism appears to be broken (48 hourssobomax2002-03-281-1/+2 * Update to 1.0.3.sobomax2002-03-263-10/+26 * Iconv cleanup, stage 2b: remove regex hacks that change iconv.h to giconv.h andsobomax2002-03-181-2/+0 * Regen after a recent addition of the PATCHFILE.sobomax2002-02-251-0/+1 * New feature: allow per-profile configuration of reply-to address. Bumpsobomax2002-02-241-1/+5 * Remove useless patches.sobomax2002-02-142-48/+0 * Fix closing parenthesis for defined()fenner2002-02-131-1/+1 * Add OpenLDAP2 support if WITH_LDAP is defined - this is a candidate forade2002-02-131-4/+9 * Update to match the realiry.sobomax2002-02-111-6/+10 * Update to 1.0.2.sobomax2002-02-086-31/+95 * Catch up changed MASTER_SITE_SUBDIR.sobomax2002-02-051-1/+1 * Don't compile/install useless statically linked versions of shared objects.sobomax2002-01-238-23/+95 * Don't compile/install useless statically linked version of shared object.sobomax2002-01-222-7/+53 * Update to 1.0.1.sobomax2002-01-148-111/+56 * Missed ${LOCALBASE}/pilot/ -> ${LOCALBASE}reg2002-01-071-1/+1 * Add gnomespell into RUN_DEPENDS, so that spell checking works right out of thesobomax2001-12-301-3/+4 * Backout previous change - it seems that new revision of the patch doesn'tsobomax2001-12-201-17/+8 * Don't filter libc_r on 5-CURRENT.sobomax2001-12-201-8/+17 * Enable SSL support. Bump PORTREVISION.sobomax2001-12-191-4/+7 * Disable LDAP support for now, because it appears that db3-3.2.9 linked withsobomax2001-12-181-5/+5 * Add LDAP support.sobomax2001-12-181-5/+5 * Make pilot support optional (controllable via WITHOUT_PILOT make(1) variable).sobomax2001-12-172-13/+21 * - Add information for fetching Ukrainian weather forecasts;sobomax2001-12-152-0/+52 * Build our own, private static db3-3.1.17 library, because Ximian recommendssobomax2001-12-155-26/+108 * Enable gnomepilot support.sobomax2001-12-144-13/+56 * Fix a bug in local timezone handling. Bump PORTREVISION.sobomax2001-12-08