aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-libxslt
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2004-07-06 11:07:06 +0800
committerbland <bland@FreeBSD.org>2004-07-06 11:07:06 +0800
commite93a9a29cffdaeac69c6b15aa466f7a6ef80e6ed (patch)
tree10d5a3eccf5219fa7016ef36aeb6f29821081b31 /textproc/py-libxslt
parent0ca41e9209454a38aa8954cba7884dd5b502f957 (diff)
downloadfreebsd-ports-gnome-e93a9a29cffdaeac69c6b15aa466f7a6ef80e6ed.tar.gz
freebsd-ports-gnome-e93a9a29cffdaeac69c6b15aa466f7a6ef80e6ed.tar.zst
freebsd-ports-gnome-e93a9a29cffdaeac69c6b15aa466f7a6ef80e6ed.zip
Add py-libxslt , Python interface for XSLT C library for GNOME.
Diffstat (limited to 'textproc/py-libxslt')
-rw-r--r--textproc/py-libxslt/Makefile32
-rw-r--r--textproc/py-libxslt/pkg-descr4
-rw-r--r--textproc/py-libxslt/pkg-plist14
3 files changed, 50 insertions, 0 deletions
diff --git a/textproc/py-libxslt/Makefile b/textproc/py-libxslt/Makefile
new file mode 100644
index 000000000000..ed3bd5e871d9
--- /dev/null
+++ b/textproc/py-libxslt/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: py-libxslt
+# Date created: 2 Jun 2004
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= textproc gnome python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Python interface for XSLT C library for GNOME
+
+MASTERDIR= ${.CURDIR}/../libxslt
+BUILD_WRKSRC= ${WRKSRC}/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOME= gnomehack lthack gnometarget libxslt
+USE_PYTHON= yes
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
+ --with-python=${LOCALBASE}
+
+DOCSDIR= ${PREFIX}/share/doc/py-libxslt
+EXAMPLESDIR= ${PREFIX}/share/examples/py-libxslt
+
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/py-libxslt/pkg-descr b/textproc/py-libxslt/pkg-descr
new file mode 100644
index 000000000000..b1582779f28a
--- /dev/null
+++ b/textproc/py-libxslt/pkg-descr
@@ -0,0 +1,4 @@
+Python interface for XSL Transformations (XSLT) library being developed
+for the GNOME project.
+
+WWW: http://xmlsoft.org/XSLT/
diff --git a/textproc/py-libxslt/pkg-plist b/textproc/py-libxslt/pkg-plist
new file mode 100644
index 000000000000..5cd5bd5d2b99
--- /dev/null
+++ b/textproc/py-libxslt/pkg-plist
@@ -0,0 +1,14 @@
+lib/%%PYTHON_VERSION%%/site-packages/libxslt.py
+lib/%%PYTHON_VERSION%%/site-packages/libxslt.pyc
+lib/%%PYTHON_VERSION%%/site-packages/libxslt.pyo
+lib/%%PYTHON_VERSION%%/site-packages/libxsltmod.so
+%%DOCSDIR%%/TODO
+%%EXAMPLESDIR%%/basic.py
+%%EXAMPLESDIR%%/exslt.py
+%%EXAMPLESDIR%%/extelem.py
+%%EXAMPLESDIR%%/extfunc.py
+%%EXAMPLESDIR%%/pyxsltproc.py
+%%EXAMPLESDIR%%/test.xml
+%%EXAMPLESDIR%%/test.xsl
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%