aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-martel
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2000-12-02 01:06:54 +0800
committerkevlo <kevlo@FreeBSD.org>2000-12-02 01:06:54 +0800
commit05fefc48d564d02b245658a02d0d783ab50d3cf8 (patch)
tree59df9edb32217d3e259a479a66af50ab667eaff2 /textproc/py-martel
parentb777cb2ad40549c07d26a8e8711bb11096738a6b (diff)
downloadfreebsd-ports-gnome-05fefc48d564d02b245658a02d0d783ab50d3cf8.tar.gz
freebsd-ports-gnome-05fefc48d564d02b245658a02d0d783ab50d3cf8.tar.zst
freebsd-ports-gnome-05fefc48d564d02b245658a02d0d783ab50d3cf8.zip
Update to version 0.4
PR: 23210 Submitted by: MAINTAINER
Diffstat (limited to 'textproc/py-martel')
-rw-r--r--textproc/py-martel/Makefile18
-rw-r--r--textproc/py-martel/distinfo2
-rw-r--r--textproc/py-martel/pkg-descr13
-rw-r--r--textproc/py-martel/pkg-plist22
4 files changed, 30 insertions, 25 deletions
diff --git a/textproc/py-martel/Makefile b/textproc/py-martel/Makefile
index 36845a6f06fd..17fb1661b76f 100644
--- a/textproc/py-martel/Makefile
+++ b/textproc/py-martel/Makefile
@@ -6,32 +6,34 @@
#
PORTNAME= martel
-PORTVERSION= 0.3.5
+PORTVERSION= 0.4
PORTEPOCH= 1
CATEGORIES= textproc biology python
MASTER_SITES= http://www.biopython.org/~dalke/Martel/
-PKGNAMEPREFIX= py-
-DISTNAME= Martel-0.35
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Martel-0.4
MAINTAINER= johann@egenetics.com
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/TextTools/__init__.py:${PORTSDIR}/textproc/py-mxTextTools
PYTHON_VERSION= python2.0
-NO_BUILD= yes
MARTEL_DIR= ${PYTHON_SITELIBDIR}/Martel
MARTEL_EXAMPLEDIR=${PREFIX}/share/examples/martel
MARTEL_DOCDIR= ${PREFIX}/share/doc/martel
+do-build:
+ @ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
do-install:
@ ${MKDIR} ${MARTEL_DIR}
- @ (cd ${WRKSRC} && find *.py examples formats test \
+ @ (cd ${WRKSRC} && find *.py *.pyc *.pyo formats test \
| cpio --quiet -pdum -R ${BINOWN}:${BINGRP} ${MARTEL_DIR})
- @ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${MARTEL_DIR}
- @ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${MARTEL_DIR}
- @ ${MKDIR} ${MARTEL_EXAMPLEDIR}
+ @ ${MKDIR} ${MARTEL_EXAMPLEDIR}/builders
@ ${INSTALL_DATA} ${WRKSRC}/examples/* ${MARTEL_EXAMPLEDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/builders/* ${MARTEL_EXAMPLEDIR}/builders
post-install:
.if !defined(NOPORTDOCS)
diff --git a/textproc/py-martel/distinfo b/textproc/py-martel/distinfo
index 008e484a8357..726f84441c80 100644
--- a/textproc/py-martel/distinfo
+++ b/textproc/py-martel/distinfo
@@ -1 +1 @@
-MD5 (Martel-0.35.tar.gz) = 8743c59c37132ecfe6a99c91f774409e
+MD5 (Martel-0.4.tar.gz) = 3f54a121b70b69f6167dd61343c73cc0
diff --git a/textproc/py-martel/pkg-descr b/textproc/py-martel/pkg-descr
index e4352842c123..2f2841f6dc3a 100644
--- a/textproc/py-martel/pkg-descr
+++ b/textproc/py-martel/pkg-descr
@@ -1,10 +1,13 @@
Martel is a parser generator, written in Python, which takes a regular
-expression grammer for a format and turns the resultant parsed tree into a
-set of callback events emulating the XML/SAX API.
+expression grammer for a file format and turns the resultant parsed tree into
+a set of callback events emulating the XML/SAX API.
-It was originally intended for use in biocomputing applications (such as
-Biopython - http://www.biopython.org/), where there is often a need to parse
-existing flat and semi-structured file formats. However, it is generally
+Essentially this means that existing and readily available XML tools can be
+used to parse non-XML flat file formats.
+
+Martel was originally intended for use in biocomputing applications (such as
+Biopython - http://www.biopython.org/) where there is often a need to parse
+flat and semi-structured legacy file formats. However, it is generally
applicable to the parsing of such files in all fields of endeavour.
More information on Martel may be found in this conference poster:
diff --git a/textproc/py-martel/pkg-plist b/textproc/py-martel/pkg-plist
index 5513064284ee..2d28c8d99a52 100644
--- a/textproc/py-martel/pkg-plist
+++ b/textproc/py-martel/pkg-plist
@@ -19,16 +19,6 @@ lib/%%PYTHON_VERSION%%/site-packages/Martel/__init__.pyo
lib/%%PYTHON_VERSION%%/site-packages/Martel/convert_re.py
lib/%%PYTHON_VERSION%%/site-packages/Martel/convert_re.pyc
lib/%%PYTHON_VERSION%%/site-packages/Martel/convert_re.pyo
-lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/README
-lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/pdb1plm.ent
-lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/sample.swissprot
-lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/swissprot2html.py
-lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/swissprot2html.pyc
-lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/swissprot2html.pyo
-lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/test.mol
-lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/toxml.py
-lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/toxml.pyc
-lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/toxml.pyo
lib/%%PYTHON_VERSION%%/site-packages/Martel/formats/MDL_10_1996.py
lib/%%PYTHON_VERSION%%/site-packages/Martel/formats/MDL_10_1996.pyc
lib/%%PYTHON_VERSION%%/site-packages/Martel/formats/MDL_10_1996.pyo
@@ -92,6 +82,9 @@ lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_Parser.pyo
lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_RecordReader.py
lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_RecordReader.pyc
lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_RecordReader.pyo
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_RecordReader2.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_RecordReader2.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_RecordReader2.pyo
lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_blastall_2_0_10.py
lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_blastall_2_0_10.pyc
lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_blastall_2_0_10.pyo
@@ -108,14 +101,21 @@ lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_swissprot38.py
lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_swissprot38.pyc
lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_swissprot38.pyo
share/examples/martel/README
+share/examples/martel/builders/SwissProtBuilder.py
+share/examples/martel/builders/SwissProtBuilder.pyc
+share/examples/martel/builders/SwissProtBuilder.pyo
share/examples/martel/pdb1plm.ent
share/examples/martel/sample.swissprot
share/examples/martel/swissprot2html.py
+share/examples/martel/swissprot2html.pyc
+share/examples/martel/swissprot2html.pyo
share/examples/martel/test.mol
share/examples/martel/toxml.py
+share/examples/martel/toxml.pyc
+share/examples/martel/toxml.pyo
+@dirrm share/examples/martel/builders
@dirrm share/examples/martel
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Martel/test
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Martel/formats
-@dirrm lib/%%PYTHON_VERSION%%/site-packages/Martel/examples
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Martel
@unexec rm -rf %D/share/doc/martel 2>/dev/null || true