aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-pyscss
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-02-02 18:05:42 +0800
committerkoobs <koobs@FreeBSD.org>2014-02-02 18:05:42 +0800
commit194d7daa513a383680784420ef53582f01288e9b (patch)
tree76971d9841aec5e7437b435695adfa48cacb5bfa /textproc/py-pyscss
parenta6a82906df396e664f25814edc9244580ffd193e (diff)
downloadfreebsd-ports-gnome-194d7daa513a383680784420ef53582f01288e9b.tar.gz
freebsd-ports-gnome-194d7daa513a383680784420ef53582f01288e9b.tar.zst
freebsd-ports-gnome-194d7daa513a383680784420ef53582f01288e9b.zip
[NEW PORT] textproc/py-scss: Compiler for SCSS flavor of the Sass language
pyScss is a compiler for SCSS flavor of the Sass language, a superset of CSS3 that adds programming capabilities and some other syntactic sugar. WWW: https://github.com/Kronuz/pyScss PR: ports/186268 Submitted by: "Ilya A. Arkhipov" <rum1cro@yandex.ru>
Diffstat (limited to 'textproc/py-pyscss')
-rw-r--r--textproc/py-pyscss/Makefile34
-rw-r--r--textproc/py-pyscss/distinfo2
-rw-r--r--textproc/py-pyscss/pkg-descr4
3 files changed, 40 insertions, 0 deletions
diff --git a/textproc/py-pyscss/Makefile b/textproc/py-pyscss/Makefile
new file mode 100644
index 000000000000..3f1007e4db80
--- /dev/null
+++ b/textproc/py-pyscss/Makefile
@@ -0,0 +1,34 @@
+# Created by: Ilya A. Arkhipov <rum1cro@yandex.ru>
+# $FreeBSD$
+
+PORTNAME= pyscss
+PORTVERSION= 1.2.0
+CATEGORIES= textproc python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rum1cro@yandex.ru
+COMMENT= Compiler for SCSS flavor of the Sass language
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest
+
+USE_GITHUB= yes
+GH_ACCOUNT= Kronuz
+GH_COMMIT= 2c10593
+GH_PROJECT= pyScss
+GH_TAGNAME= v${PORTVERSION}
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+regression-test: build
+ @cd ${WRKSRC} && py.test
+
+.include <bsd.port.mk>
diff --git a/textproc/py-pyscss/distinfo b/textproc/py-pyscss/distinfo
new file mode 100644
index 000000000000..85557b39000c
--- /dev/null
+++ b/textproc/py-pyscss/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyscss-1.2.0.tar.gz) = 0490325a50ad1e4d8defb6e8f422fa559a1c9f06b84048b2e4897a6e139d5c36
+SIZE (pyscss-1.2.0.tar.gz) = 281058
diff --git a/textproc/py-pyscss/pkg-descr b/textproc/py-pyscss/pkg-descr
new file mode 100644
index 000000000000..91169a6bd336
--- /dev/null
+++ b/textproc/py-pyscss/pkg-descr
@@ -0,0 +1,4 @@
+pyScss is a compiler for SCSS flavor of the Sass language, a superset of CSS3
+that adds programming capabilities and some other syntactic sugar.
+
+WWW: https://github.com/Kronuz/pyScss