aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-qrcode/Makefile
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2015-01-24 18:16:48 +0800
committerxmj <xmj@FreeBSD.org>2015-01-24 18:16:48 +0800
commit28ff7d523451125ebe71b0696d61c65acfdc9602 (patch)
treefe804b9f3c5c70531c6b33688d8fbf555be090e1 /textproc/py-qrcode/Makefile
parent0e2361b90199a0e4212569e6eaf8f7b6302c9eb1 (diff)
downloadfreebsd-ports-gnome-28ff7d523451125ebe71b0696d61c65acfdc9602.tar.gz
freebsd-ports-gnome-28ff7d523451125ebe71b0696d61c65acfdc9602.tar.zst
freebsd-ports-gnome-28ff7d523451125ebe71b0696d61c65acfdc9602.zip
textproc/py-qrcode: Add port
This module uses image libraries, Python Imaging Library (PIL) by default, to generate QR Codes. A Quick Response code is a two-dimensional pictographic code used for its fast readability and comparatively large storage capacity. The code consists of black modules arranged in a square pattern on a white background. The information encoded can be made up of any kind of data (e.g., binary, alphanumeric, or Kanji symbols) WWW: https://github.com/lincolnloop/python-qrcode PR: 196046 Differential Revision: https://reviews.freebsd.org/D1631 Submitted by: kyuupichan@gmail.com Approved by: koobs (mentor)
Diffstat (limited to 'textproc/py-qrcode/Makefile')
-rw-r--r--textproc/py-qrcode/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/textproc/py-qrcode/Makefile b/textproc/py-qrcode/Makefile
new file mode 100644
index 000000000000..2494aa326845
--- /dev/null
+++ b/textproc/py-qrcode/Makefile
@@ -0,0 +1,21 @@
+# Created by: Neil Booth
+# $FreeBSD$
+
+PORTNAME= qrcode
+PORTVERSION= 5.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kyuupichan@gmail.com
+COMMENT= QR Code image generator
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.8:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=2.6:${PORTSDIR}/graphics/py-pillow
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>