aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-sgrep/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-06-14 02:49:51 +0800
committerijliao <ijliao@FreeBSD.org>2001-06-14 02:49:51 +0800
commitdf2040fb0d8725037ffe58a4ab9a85fac7f30232 (patch)
tree69ae576ced31ed1da8fb4c804e234a0c35cad225 /textproc/py-sgrep/Makefile
parent8c89de6c828b543a462d2ea1a465aec996d9d77d (diff)
downloadfreebsd-ports-gnome-df2040fb0d8725037ffe58a4ab9a85fac7f30232.tar.gz
freebsd-ports-gnome-df2040fb0d8725037ffe58a4ab9a85fac7f30232.tar.zst
freebsd-ports-gnome-df2040fb0d8725037ffe58a4ab9a85fac7f30232.zip
add py-sgrep
Python wrappers for Sgrep
Diffstat (limited to 'textproc/py-sgrep/Makefile')
-rw-r--r--textproc/py-sgrep/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/py-sgrep/Makefile b/textproc/py-sgrep/Makefile
new file mode 100644
index 000000000000..9e10b0dd8204
--- /dev/null
+++ b/textproc/py-sgrep/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: py-sgrep
+# Date created: Jun 14, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sgrep
+PORTVERSION= 1.0a
+CATEGORIES= textproc python
+MASTER_SITES= http://www.rexx.com/~dkuhlman/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pysgrep-${PORTVERSION}
+
+MAINTAINER= ijliao@freebsd.org
+
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+
+do-build:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py build)
+
+do-install:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py install)
+
+.include <bsd.port.mk>