aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-syck
diff options
context:
space:
mode:
authordd <dd@FreeBSD.org>2004-12-02 20:09:25 +0800
committerdd <dd@FreeBSD.org>2004-12-02 20:09:25 +0800
commit54cd2cd0fff06e14099ae34ab1ee7905d82678db (patch)
tree5036cbd79a6098f2ea49470f88d842e7daddaa3a /textproc/py-syck
parent6527c63ca67725583b29157ed1131a2362b22361 (diff)
downloadfreebsd-ports-gnome-54cd2cd0fff06e14099ae34ab1ee7905d82678db.tar.gz
freebsd-ports-gnome-54cd2cd0fff06e14099ae34ab1ee7905d82678db.tar.zst
freebsd-ports-gnome-54cd2cd0fff06e14099ae34ab1ee7905d82678db.zip
Python binding for Syck, a YAML parser and emitter
Diffstat (limited to 'textproc/py-syck')
-rw-r--r--textproc/py-syck/Makefile29
-rw-r--r--textproc/py-syck/distinfo2
-rw-r--r--textproc/py-syck/pkg-descr10
-rw-r--r--textproc/py-syck/pkg-plist1
4 files changed, 42 insertions, 0 deletions
diff --git a/textproc/py-syck/Makefile b/textproc/py-syck/Makefile
new file mode 100644
index 000000000000..a3dd49a29e16
--- /dev/null
+++ b/textproc/py-syck/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-syck
+# Date created: 2 December 2004
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= syck
+PORTVERSION= 0.45
+CATEGORIES= textproc devel
+MASTER_SITES= http://rubyforge.org/frs/download.php/1371/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dd@FreeBSD.org
+COMMENT= Python binding for Syck, a YAML parser and emitter
+
+# Just a build dependency because the library will be linked into the extension
+BUILD_DEPENDS= syck:${PORTSDIR}/textproc/syck
+
+SITELIBDIR= %%PYTHON_SITELIBDIR%%/
+PYFILES= ypath.py ydump.py yaml2xml.py
+PYFILES_= ${PYFILES:S/^/${SITELIBDIR}/}
+PLIST_FILES= ${PYFILES_} ${PYFILES_:S/$/c/} ${PYFILES_:S/$/o/}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/ext/python
+
+.include <bsd.port.mk>
diff --git a/textproc/py-syck/distinfo b/textproc/py-syck/distinfo
new file mode 100644
index 000000000000..07a6fd1f2cac
--- /dev/null
+++ b/textproc/py-syck/distinfo
@@ -0,0 +1,2 @@
+MD5 (syck-0.45.tar.gz) = 8071e1e2ee255576f025b4cef8feee62
+SIZE (syck-0.45.tar.gz) = 281607
diff --git a/textproc/py-syck/pkg-descr b/textproc/py-syck/pkg-descr
new file mode 100644
index 000000000000..17a8c9a72cfc
--- /dev/null
+++ b/textproc/py-syck/pkg-descr
@@ -0,0 +1,10 @@
+Python binding for Syck, which, according is, according to the web site:
+
+ Syck is an extension for reading and writing YAML swiftly in popular
+ scripting languages. As Syck loads the YAML, it stores the data
+ directly in your language's symbol table. This means speed. This
+ means power. This means Do not disturb Syck because it is so focused
+ on the task at hand that it will slay you mortally if you get in its
+ way.
+
+WWW: http://www.whytheluckystiff.net/syck/
diff --git a/textproc/py-syck/pkg-plist b/textproc/py-syck/pkg-plist
new file mode 100644
index 000000000000..aebc3195d783
--- /dev/null
+++ b/textproc/py-syck/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/syck.so