aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-toml
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2018-05-29 12:32:35 +0800
committervanilla <vanilla@FreeBSD.org>2018-05-29 12:32:35 +0800
commit571ed2eb8792babdaf3616890369dffd3b2487c7 (patch)
tree2cc6fd098319fdf6202b23ebe182c45ca8acea72 /textproc/py-toml
parent0d7c8988a66045bd0f6883fe34fca2657a696f4d (diff)
downloadfreebsd-ports-gnome-571ed2eb8792babdaf3616890369dffd3b2487c7.tar.gz
freebsd-ports-gnome-571ed2eb8792babdaf3616890369dffd3b2487c7.tar.zst
freebsd-ports-gnome-571ed2eb8792babdaf3616890369dffd3b2487c7.zip
Add py-toml 0.9.4, python library for parsing and creating TOML.
PR: 228528 Submitted by: Waitman Gobble <waitman@waitman.net>
Diffstat (limited to 'textproc/py-toml')
-rw-r--r--textproc/py-toml/Makefile28
-rw-r--r--textproc/py-toml/distinfo3
-rw-r--r--textproc/py-toml/pkg-descr4
3 files changed, 35 insertions, 0 deletions
diff --git a/textproc/py-toml/Makefile b/textproc/py-toml/Makefile
new file mode 100644
index 000000000000..e042698fa1b0
--- /dev/null
+++ b/textproc/py-toml/Makefile
@@ -0,0 +1,28 @@
+# Created by: Waitman Gobble <waitman@waitman.net>
+# $FreeBSD$
+
+PORTNAME= toml
+PORTVERSION= 0.9.4
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Python library for parsing and creating TOML
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+OPTIONS_DEFINE= DOCS
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+PORTDOCS= README.rst
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/py-toml/distinfo b/textproc/py-toml/distinfo
new file mode 100644
index 000000000000..e94868090259
--- /dev/null
+++ b/textproc/py-toml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1527389739
+SHA256 (toml-0.9.4.tar.gz) = 8e86bd6ce8cc11b9620cb637466453d94f5d57ad86f17e98a98d1f73e3baab2d
+SIZE (toml-0.9.4.tar.gz) = 12752
diff --git a/textproc/py-toml/pkg-descr b/textproc/py-toml/pkg-descr
new file mode 100644
index 000000000000..1a65ad4eeac3
--- /dev/null
+++ b/textproc/py-toml/pkg-descr
@@ -0,0 +1,4 @@
+A Python library for parsing and creating TOML.
+Tom's Obvious, Minimal Language
+
+WWW: https://pypi.org/project/toml/