aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-xlwriter/Makefile
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-15 00:31:39 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-15 00:31:39 +0800
commitdb40c8038d46b3124933ae36270fb8dd40b1de24 (patch)
tree58849caba0deb693050108b575799ac5931152cb /textproc/py-xlwriter/Makefile
parentb06cb03cd3b364f83d4081f62f256138afe054d5 (diff)
downloadfreebsd-ports-gnome-db40c8038d46b3124933ae36270fb8dd40b1de24.tar.gz
freebsd-ports-gnome-db40c8038d46b3124933ae36270fb8dd40b1de24.tar.zst
freebsd-ports-gnome-db40c8038d46b3124933ae36270fb8dd40b1de24.zip
Add py-xlwriter.
pyXLWriter is a Python library for generating Excel-compatible spreadsheets. It's a port of John McNamara's Perl Spreadsheet::WriteExcel module (see http://www.cpan.org) to Python. WWW: http://pyxlwriter.sourceforge.net/ PR: ports/80930 Submitted by: Choe Cheng-Dae <whitekid@gmail.com>
Diffstat (limited to 'textproc/py-xlwriter/Makefile')
-rw-r--r--textproc/py-xlwriter/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/py-xlwriter/Makefile b/textproc/py-xlwriter/Makefile
new file mode 100644
index 000000000000..b6bfd8e89f36
--- /dev/null
+++ b/textproc/py-xlwriter/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-xlwriter
+# Date created: 12 May 2005
+# Whom: Choe, Cheng-Dae
+#
+# $FreeBSD$
+#
+
+PORTNAME= xlwriter
+PORTVERSION= 0.4a3
+CATEGORIES= textproc python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pyxlwriter
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyXLWriter-${PORTVERSION}
+
+MAINTAINER= whitekid@gmail.com
+COMMENT= A python library for generating Excel-compatible spreadsheets
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_ZIP= yes
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${FIND} ${WRKSRC}/examples -type f -exec ${INSTALL_DATA} {} ${EXAMPLESDIR} \;
+
+.include <bsd.port.mk>