aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/queequeg
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-02-29 22:36:36 +0800
committerpav <pav@FreeBSD.org>2004-02-29 22:36:36 +0800
commit5f123ed82c36485355d3ededaec43e1c125c229a (patch)
treef497771fb9df06eb7766e13eb59bd06492c03dd9 /textproc/queequeg
parentb86970836ce26aecf7974d69dbba8e5b690e4386 (diff)
downloadfreebsd-ports-gnome-5f123ed82c36485355d3ededaec43e1c125c229a.tar.gz
freebsd-ports-gnome-5f123ed82c36485355d3ededaec43e1c125c229a.tar.zst
freebsd-ports-gnome-5f123ed82c36485355d3ededaec43e1c125c229a.zip
Add queequeg, a tiny English grammar checker for non-native speakers who
are not used to verb conjugation and number agreement. We especially focus on people who're writing academic papers or business documents where thorough checking is required. We aim to reduce this laborious work with automated checking. PR: ports/63472 Submitted by: Kimura Fuyuki <fuyuki@nigredo.org>
Diffstat (limited to 'textproc/queequeg')
-rw-r--r--textproc/queequeg/Makefile38
-rw-r--r--textproc/queequeg/distinfo2
-rw-r--r--textproc/queequeg/pkg-descr7
-rw-r--r--textproc/queequeg/pkg-plist19
4 files changed, 66 insertions, 0 deletions
diff --git a/textproc/queequeg/Makefile b/textproc/queequeg/Makefile
new file mode 100644
index 000000000000..8aab640916d8
--- /dev/null
+++ b/textproc/queequeg/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Queequeg
+# Date created: 28 February 2004
+# Whom: Kimura Fuyuki <fuyuki@nigredo.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= queequeg
+PORTVERSION= 0.91
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= fuyuki@nigredo.org
+COMMENT= A tiny English grammar checker
+
+BUILD_DEPENDS= wn:${PORTSDIR}/textproc/wordnet \
+ ${PYTHON_SITELIBDIR}/cdbmodule.so:${PORTSDIR}/databases/py-cdb
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cdbmodule.so:${PORTSDIR}/databases/py-cdb
+
+USE_PYTHON= 2.3+
+MAKE_ARGS= dict WORDNETDICT="${LOCALBASE}/share/WordNet-*"
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= address.png index-e.html index.html
+.endif
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/qq ${DATADIR}
+ ${LN} -shf ${DATADIR}/qq ${PREFIX}/bin/qq
+ ${INSTALL_DATA} ${WRKSRC}/*.py ${WRKSRC}/dict.cdb ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/htdocs; ${INSTALL_DATA} * ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/queequeg/distinfo b/textproc/queequeg/distinfo
new file mode 100644
index 000000000000..5251e7627e66
--- /dev/null
+++ b/textproc/queequeg/distinfo
@@ -0,0 +1,2 @@
+MD5 (queequeg-0.91.tar.gz) = 70d9d5d66206abaa505cbfee6f5c63db
+SIZE (queequeg-0.91.tar.gz) = 69449
diff --git a/textproc/queequeg/pkg-descr b/textproc/queequeg/pkg-descr
new file mode 100644
index 000000000000..ba650986cf9a
--- /dev/null
+++ b/textproc/queequeg/pkg-descr
@@ -0,0 +1,7 @@
+Queequeg is a tiny English grammar checker for non-native speakers who
+are not used to verb conjugation and number agreement. We especially
+focus on people who're writing academic papers or business documents
+where thorough checking is required. We aim to reduce this laborious
+work with automated checking.
+
+WWW: http://queequeg.sourceforge.net/index-e.html
diff --git a/textproc/queequeg/pkg-plist b/textproc/queequeg/pkg-plist
new file mode 100644
index 000000000000..f7c3f7146124
--- /dev/null
+++ b/textproc/queequeg/pkg-plist
@@ -0,0 +1,19 @@
+bin/qq
+%%DATADIR%%/abstfilter.py
+%%DATADIR%%/constraint.py
+%%DATADIR%%/convdict.py
+%%DATADIR%%/dict.cdb
+%%DATADIR%%/dictionary.py
+%%DATADIR%%/document.py
+%%DATADIR%%/grammarerror.py
+%%DATADIR%%/markupbase_rev.py
+%%DATADIR%%/output.py
+%%DATADIR%%/postagfix.py
+%%DATADIR%%/pstring.py
+%%DATADIR%%/qq
+%%DATADIR%%/regpat.py
+%%DATADIR%%/sentence.py
+%%DATADIR%%/sgmllib_rev.py
+%%DATADIR%%/texparser.py
+%%DATADIR%%/unification.py
+@dirrm %%DATADIR%%