aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/raptor2
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-02-02 22:55:53 +0800
committernork <nork@FreeBSD.org>2003-02-02 22:55:53 +0800
commit3a9fbf363272ada89fbcbec25f92fc278e6a23c7 (patch)
tree2dfa860bd530c5db02398b944104df2128a5f769 /textproc/raptor2
parent207220a95de55f1a9a6219faf0bd54db939ca514 (diff)
downloadfreebsd-ports-gnome-3a9fbf363272ada89fbcbec25f92fc278e6a23c7.tar.gz
freebsd-ports-gnome-3a9fbf363272ada89fbcbec25f92fc278e6a23c7.tar.zst
freebsd-ports-gnome-3a9fbf363272ada89fbcbec25f92fc278e6a23c7.zip
Conditionalize libgnugetopt dependencies.
PR: ports/47758 Submitted by: Ports Fury
Diffstat (limited to 'textproc/raptor2')
-rw-r--r--textproc/raptor2/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/textproc/raptor2/Makefile b/textproc/raptor2/Makefile
index 520456ea6c42..013aacbe1e66 100644
--- a/textproc/raptor2/Makefile
+++ b/textproc/raptor2/Makefile
@@ -16,8 +16,7 @@ MASTER_SITE_SUBDIR= librdf
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- xml2.5:${PORTSDIR}/textproc/libxml2 \
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
xmlparse.1:${PORTSDIR}/www/libwww
LIBWWW_CONFIG= ${LOCALBASE}/bin/libwww-config
@@ -30,7 +29,12 @@ INSTALLS_SHLIB= yes
MAN1= rdfdump.1
MAN3= libraptor.3
-CPPFLAGS= -I${LOCALBASE}/include `${LIBWWW_CONFIG} --cflags`
-LDFLAGS= -L${LOCALBASE}/lib -lgnugetopt `${LIBWWW_CONFIG} --libs`
+CPPFLAGS+= -I${LOCALBASE}/include `${LIBWWW_CONFIG} --cflags`
+LDFLAGS+= -L${LOCALBASE}/lib `${LIBWWW_CONFIG} --libs`
+
+.if !exists(/usr/include/getopt.h)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LDFLAGS+= -lgnugetopt
+.endif
.include <bsd.port.mk>