aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/redet
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-07-20 18:46:36 +0800
committersem <sem@FreeBSD.org>2005-07-20 18:46:36 +0800
commitd77570cfc9728874234807fcf80a055ba6d7357e (patch)
tree5e40e449df2d56b3e1f8d9816849a26da5ac4b81 /textproc/redet
parentf19c5b0fa0e94d21d7090e04c4bc43573bd76a3d (diff)
downloadfreebsd-ports-gnome-d77570cfc9728874234807fcf80a055ba6d7357e.tar.gz
freebsd-ports-gnome-d77570cfc9728874234807fcf80a055ba6d7357e.tar.zst
freebsd-ports-gnome-d77570cfc9728874234807fcf80a055ba6d7357e.zip
Redet allows the user to construct regular expressions and test them against
input data. Written on TCL/Tk. PR: ports/83664 Submitted by: Vsevolod Stakhov <vsevolod@highsecure.ru>
Diffstat (limited to 'textproc/redet')
-rw-r--r--textproc/redet/Makefile42
-rw-r--r--textproc/redet/distinfo2
-rw-r--r--textproc/redet/pkg-descr16
3 files changed, 60 insertions, 0 deletions
diff --git a/textproc/redet/Makefile b/textproc/redet/Makefile
new file mode 100644
index 000000000000..062b95a77d51
--- /dev/null
+++ b/textproc/redet/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: redet
+# Date created: 2005-07-18
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= redet
+PORTVERSION= 6.12
+CATEGORIES= textproc tk84
+MASTER_SITES= http://www.cis.upenn.edu/~wjposer/.downloads/
+DISTNAME= ${PORTNAME}tiny-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= Visual regexp constructors with many regexp types support
+
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+PORTDOCS= BUGS COPYING CREDITS LICENSE README
+MAN1= redet.1
+PLIST_FILES= bin/redet
+PATCH_TK_SCRIPTS= redet.tcl
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/wish/wish8.4/' ${WRKSRC}/redet.tcl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/redet.tcl ${PREFIX}/bin/redet
+ ${INSTALL_DATA} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/redet/distinfo b/textproc/redet/distinfo
new file mode 100644
index 000000000000..16467c8f140a
--- /dev/null
+++ b/textproc/redet/distinfo
@@ -0,0 +1,2 @@
+MD5 (redettiny-6.12.tgz) = 35ddb962b0e61a15c8503c755f4a7f82
+SIZE (redettiny-6.12.tgz) = 127314
diff --git a/textproc/redet/pkg-descr b/textproc/redet/pkg-descr
new file mode 100644
index 000000000000..323153150b85
--- /dev/null
+++ b/textproc/redet/pkg-descr
@@ -0,0 +1,16 @@
+Redet allows the user to construct regular expressions and test them against
+input data by executing any of a variety of search programs, editors, and
+programming languages that make use of regular expressions. When a suitable
+regular expression has been constructed it may be saved to a file. redet stands
+for Regular Expression Development and Execution Tool. For each program, a
+palette showing the available regular expression syntax is provided. Selections
+from the palette may be copied to the regular expression window with a mouse
+click. Users may add their own definitions to the palette via their
+initialization file. Redet also keeps a list of the regular expressions
+executed, from which entries may be copied back into the regular expression
+under construction. The history list is saved to a file and restored on
+startup, so it persists across sessions. So long as the underlying program
+supports Unicode, redet allows UTF-8 Unicode in both test data and regular
+expressions
+
+WWW: http://www.cis.upenn.edu/~wjposer/redet.html