aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/replaceit
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-08-25 03:21:32 +0800
committerpetef <petef@FreeBSD.org>2001-08-25 03:21:32 +0800
commit0d8192336b6b9d9c3e7936403b2ee9163665fcb9 (patch)
tree266f4a41f1952ab192207bb8d3ad43a2c19f7f4c /textproc/replaceit
parent8210a6d5254e50325daaa0f0fab2b33b3ba93dd8 (diff)
downloadfreebsd-ports-gnome-0d8192336b6b9d9c3e7936403b2ee9163665fcb9.tar.gz
freebsd-ports-gnome-0d8192336b6b9d9c3e7936403b2ee9163665fcb9.tar.zst
freebsd-ports-gnome-0d8192336b6b9d9c3e7936403b2ee9163665fcb9.zip
add replaceit 1.0.0
A light replacement to the combination of sed/awk/grep/head/tail PR: 29837 Submitted by: Patrick Li <pat@databits.net>
Diffstat (limited to 'textproc/replaceit')
-rw-r--r--textproc/replaceit/Makefile18
-rw-r--r--textproc/replaceit/distinfo1
-rw-r--r--textproc/replaceit/files/patch-Makefile18
-rw-r--r--textproc/replaceit/pkg-comment1
-rw-r--r--textproc/replaceit/pkg-descr9
-rw-r--r--textproc/replaceit/pkg-plist1
6 files changed, 48 insertions, 0 deletions
diff --git a/textproc/replaceit/Makefile b/textproc/replaceit/Makefile
new file mode 100644
index 000000000000..8136630355fc
--- /dev/null
+++ b/textproc/replaceit/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: replaceit
+# Date created: Fri Aug 17 20:15:02 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= replaceit
+PORTVERSION= 1.0.0
+CATEGORIES= textproc
+MASTER_SITES= http://pldaniels.com/replaceit/
+
+MAINTAINER= pat@databits.net
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/replaceit ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/replaceit/distinfo b/textproc/replaceit/distinfo
new file mode 100644
index 000000000000..5acfa80170d1
--- /dev/null
+++ b/textproc/replaceit/distinfo
@@ -0,0 +1 @@
+MD5 (replaceit-1.0.0.tar.gz) = d6455d616df1f3d7fdad8de8dc4d4379
diff --git a/textproc/replaceit/files/patch-Makefile b/textproc/replaceit/files/patch-Makefile
new file mode 100644
index 000000000000..0a3577ade6a8
--- /dev/null
+++ b/textproc/replaceit/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig Fri Aug 17 20:18:18 2001
++++ Makefile Fri Aug 17 20:20:35 2001
+@@ -1,12 +1,11 @@
+-PRF=-O2 -Wall
+-CC=cc
++CFLAGS+= -Wall
++all: replaceit
+
+ replaceit: replaceit.c
+- $(CC) $(PRF) replaceit.c -o replaceit
++ $(CC) $(CFLAGS) $< -o $@
+
+ clean:
+ rm replaceit
+
+-all: install
+ install: replaceit
+ cp replaceit /usr/local/bin
diff --git a/textproc/replaceit/pkg-comment b/textproc/replaceit/pkg-comment
new file mode 100644
index 000000000000..7bad6430483a
--- /dev/null
+++ b/textproc/replaceit/pkg-comment
@@ -0,0 +1 @@
+A light replacement to the combination of sed/awk/grep/head/tail
diff --git a/textproc/replaceit/pkg-descr b/textproc/replaceit/pkg-descr
new file mode 100644
index 000000000000..649055628420
--- /dev/null
+++ b/textproc/replaceit/pkg-descr
@@ -0,0 +1,9 @@
+ReplaceIt was written as a quick, light and effective replacement to
+the combination of sed/awk/grep/head/tail and other such shell
+utilities, as well as being quicker in startup (at least) than an
+equivilant Perl solution.
+
+WWW: http://pldaniels.com/replaceit/
+Author: Paul L Daniels <pldaniels@pldaniels.com>
+
+- Patrick Li <pat@databits.net>
diff --git a/textproc/replaceit/pkg-plist b/textproc/replaceit/pkg-plist
new file mode 100644
index 000000000000..d33d811aed38
--- /dev/null
+++ b/textproc/replaceit/pkg-plist
@@ -0,0 +1 @@
+bin/replaceit