aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/rst.el
diff options
context:
space:
mode:
authoranray <anray@FreeBSD.org>2006-08-23 13:35:57 +0800
committeranray <anray@FreeBSD.org>2006-08-23 13:35:57 +0800
commit5ecb21409ee19cf3f3f9d1c5d49567d4566f55ed (patch)
tree4f2e9b5bb1b7c2e48cb61306a9f83be1f946e335 /textproc/rst.el
parentfbfc752ee56d702d7aa1f377ff627fba2760bad9 (diff)
downloadfreebsd-ports-gnome-5ecb21409ee19cf3f3f9d1c5d49567d4566f55ed.tar.gz
freebsd-ports-gnome-5ecb21409ee19cf3f3f9d1c5d49567d4566f55ed.tar.zst
freebsd-ports-gnome-5ecb21409ee19cf3f3f9d1c5d49567d4566f55ed.zip
Support code for editing reStructuredText with Emacs.
Basically, this package contains: - Functions to automatically adjust and cycle the section underline decorations; - A mode that displays the table of contents and allows you to jump anywhere from it; - Functions to insert and automatically update a TOC in your source document; - A mode which supports font-lock highlighting of reStructuredText structures; - Some other convenience functions. This package is the result of merging: - restructuredtext.el - rst-mode.el - rst-html.el Those files are now OBSOLETE and have been replaced by this single package file (2005-10-30). WWW: http://docutils.sourceforge.net/docs/user/emacs.html PR: ports/102384 Submitted by: Denis Shaposhnikov <dsh at vlink.ru>
Diffstat (limited to 'textproc/rst.el')
-rw-r--r--textproc/rst.el/Makefile42
-rw-r--r--textproc/rst.el/distinfo3
-rw-r--r--textproc/rst.el/files/patch-rst.el26
-rw-r--r--textproc/rst.el/pkg-descr24
-rw-r--r--textproc/rst.el/pkg-message6
5 files changed, 101 insertions, 0 deletions
diff --git a/textproc/rst.el/Makefile b/textproc/rst.el/Makefile
new file mode 100644
index 000000000000..306c106b8ae5
--- /dev/null
+++ b/textproc/rst.el/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: rst.el
+# Date created: Sun Aug 20 18:39:03 MSD 2006
+# Whom: Denis Shaposhnikov <dsh@vlink.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rst.el
+PORTVERSION= 4655
+CATEGORIES= textproc elisp
+MASTER_SITES= http://svn.berlios.de/viewcvs/*checkout*/docutils/trunk/docutils/tools/editors/emacs/
+PKGNAMESUFFIX= -${EMACS_NAME}
+DISTNAME= rst.el\?rev=${PORTVERSION}
+EXTRACT_SUFX= # empty
+
+MAINTAINER= dsh@vlink.ru
+COMMENT= ReStructuredText Support for Emacs
+
+USE_EMACS= yes
+EMACS_PORT_NAME?= xemacs21-mule
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= # empty
+EXTRACT_AFTER_ARGS= ${WRKSRC}/rst.el
+
+PLIST_FILES= ${EMACS_SITE_LISPDIR}/rst.el \
+ ${EMACS_SITE_LISPDIR}/rst.elc
+
+ELISPDIR= ${TARGETDIR}/${EMACS_SITE_LISPDIR}
+
+do-build:
+ cd ${WRKSRC}; ${EMACS_CMD} -batch -q -f batch-byte-compile ${PORTNAME}
+
+do-install:
+ ${MKDIR} ${ELISPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}c ${ELISPDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/textproc/rst.el/distinfo b/textproc/rst.el/distinfo
new file mode 100644
index 000000000000..a9a3d6b92c48
--- /dev/null
+++ b/textproc/rst.el/distinfo
@@ -0,0 +1,3 @@
+MD5 (rst.el?rev=4655) = 825b249a63351fd76450427a30a0c5ab
+SHA256 (rst.el?rev=4655) = eef04f0b37b6b26c6ab028184e94784cee5e28f8e83ac01f1f03d3d01b2442cf
+SIZE (rst.el?rev=4655) = 112401
diff --git a/textproc/rst.el/files/patch-rst.el b/textproc/rst.el/files/patch-rst.el
new file mode 100644
index 000000000000..12fc5fc5595f
--- /dev/null
+++ b/textproc/rst.el/files/patch-rst.el
@@ -0,0 +1,26 @@
+--- rst.el.orig Sun Aug 20 18:19:59 2006
++++ rst.el Sun Aug 20 17:41:37 2006
+@@ -930,7 +930,9 @@
+ (toggle-style
+ (and current-prefix-arg (not reverse-direction))))
+
+- (if (and transient-mark-mode mark-active)
++ (if (or
++ (and (fboundp 'region-active-p) (region-active-p) (region-exists-p))
++ (and (boundp 'transient-mark-mode) transient-mark-mode mark-active))
+ ;; Adjust decorations within region.
+ (rst-promote-region current-prefix-arg)
+ ;; Adjust decoration around point.
+@@ -1988,7 +1990,11 @@
+ (error "Cannot mark zero sections"))
+ (cond ((and allow-extend
+ (or (and (eq last-command this-command) (mark t))
+- (and transient-mark-mode mark-active)))
++ (or
++ (and (fboundp 'region-active-p)
++ (region-active-p) (region-exists-p))
++ (and (boundp 'transient-mark-mode)
++ transient-mark-mode mark-active))))
+ (set-mark
+ (save-excursion
+ (goto-char (mark))
diff --git a/textproc/rst.el/pkg-descr b/textproc/rst.el/pkg-descr
new file mode 100644
index 000000000000..32c7a8b23939
--- /dev/null
+++ b/textproc/rst.el/pkg-descr
@@ -0,0 +1,24 @@
+Support code for editing reStructuredText with Emacs.
+
+Basically, this package contains:
+
+- Functions to automatically adjust and cycle the section underline
+ decorations;
+- A mode that displays the table of contents and allows you to jump anywhere
+ from it;
+- Functions to insert and automatically update a TOC in your source
+ document;
+- A mode which supports font-lock highlighting of reStructuredText
+ structures;
+- Some other convenience functions.
+
+This package is the result of merging:
+
+- restructuredtext.el
+- rst-mode.el
+- rst-html.el
+
+Those files are now OBSOLETE and have been replaced by this single
+package file (2005-10-30).
+
+WWW: http://docutils.sourceforge.net/docs/user/emacs.html
diff --git a/textproc/rst.el/pkg-message b/textproc/rst.el/pkg-message
new file mode 100644
index 000000000000..8c17f5cc2d20
--- /dev/null
+++ b/textproc/rst.el/pkg-message
@@ -0,0 +1,6 @@
+
+To use rst.el, add the following line to your ~/.emacs or init.el:
+
+ (require 'rst)
+ (add-hook 'text-mode-hook 'rst-text-mode-bindings)
+