aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/rtf2html
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-08 04:50:06 +0800
committerpav <pav@FreeBSD.org>2005-07-08 04:50:06 +0800
commit32975274ca6d5748fd4da7359b7435e2b32e78ab (patch)
tree5a692bf0086b7fc6ca42220ec01b4bbd294456f7 /textproc/rtf2html
parentf452d800dec7ef59d399b7cc8454028e9fdb0fe7 (diff)
downloadfreebsd-ports-gnome-32975274ca6d5748fd4da7359b7435e2b32e78ab.tar.gz
freebsd-ports-gnome-32975274ca6d5748fd4da7359b7435e2b32e78ab.tar.zst
freebsd-ports-gnome-32975274ca6d5748fd4da7359b7435e2b32e78ab.zip
A simple rtf2html converter. If no file is specified rtf2html reads from
standard input. PR: ports/83057 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'textproc/rtf2html')
-rw-r--r--textproc/rtf2html/Makefile26
-rw-r--r--textproc/rtf2html/distinfo2
-rw-r--r--textproc/rtf2html/pkg-descr7
3 files changed, 35 insertions, 0 deletions
diff --git a/textproc/rtf2html/Makefile b/textproc/rtf2html/Makefile
new file mode 100644
index 000000000000..c06ce20e1e42
--- /dev/null
+++ b/textproc/rtf2html/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: rtf2html
+# Date created: 6 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rtf2html
+DISTVERSION= 1.1b
+CATEGORIES= textproc
+MASTER_SITES= http://www.45.free.net/~vitus/ice/misc/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A simple rtf2html converter
+
+CFLAGS+= -Wall -Werror
+PLIST_FILES= bin/rtf2html
+
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/rtf2html/distinfo b/textproc/rtf2html/distinfo
new file mode 100644
index 000000000000..093944388a5e
--- /dev/null
+++ b/textproc/rtf2html/distinfo
@@ -0,0 +1,2 @@
+MD5 (rtf2html.tar.gz) = 823949bf2e1a7fc9d090fd2035b2e828
+SIZE (rtf2html.tar.gz) = 5548
diff --git a/textproc/rtf2html/pkg-descr b/textproc/rtf2html/pkg-descr
new file mode 100644
index 000000000000..59f56a1fa89a
--- /dev/null
+++ b/textproc/rtf2html/pkg-descr
@@ -0,0 +1,7 @@
+A simple rtf2html converter. If no file is specified rtf2html reads from
+standard input.
+
+WWW: http://www.45.free.net/~vitus/ice/misc/
+
+- ehaupt
+ehaupt@critical.ch