aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ruby-gdome/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-07-12 14:46:03 +0800
committerknu <knu@FreeBSD.org>2001-07-12 14:46:03 +0800
commitf44f64eaa793e7eec7945fc935a075ba7be6b370 (patch)
treefdc20ee31b24668e5ca8ca26c944023d063e7684 /textproc/ruby-gdome/Makefile
parentaa63add5a7eaa749931d9c228510c6fe0f7f507f (diff)
downloadfreebsd-ports-gnome-f44f64eaa793e7eec7945fc935a075ba7be6b370.tar.gz
freebsd-ports-gnome-f44f64eaa793e7eec7945fc935a075ba7be6b370.tar.zst
freebsd-ports-gnome-f44f64eaa793e7eec7945fc935a075ba7be6b370.zip
Add ruby-gdome, a Ruby extension that wraps around gdome2.
Diffstat (limited to 'textproc/ruby-gdome/Makefile')
-rw-r--r--textproc/ruby-gdome/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/ruby-gdome/Makefile b/textproc/ruby-gdome/Makefile
new file mode 100644
index 000000000000..cbd756b0050f
--- /dev/null
+++ b/textproc/ruby-gdome/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libgdome-ruby
+# Date created: 12 July 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdome
+PORTVERSION= 0.1
+CATEGORIES= textproc ruby
+MASTER_SITES= http://download.berlios.de/libgdome-ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= lib${PORTNAME}-ruby-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= gdome.6:${PORTSDIR}/textproc/gdome2
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>