aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ruby-html-parser/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
committerknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
commite932a87c5235b90fa671f5b453afd18c94f3b2f3 (patch)
tree7f470d6c370885834b1ad0e7ffcd9a38f0534974 /textproc/ruby-html-parser/Makefile
parent761a287d6d458a83abfd6ab90410b27c5cda14af (diff)
downloadfreebsd-ports-gnome-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.gz
freebsd-ports-gnome-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.zst
freebsd-ports-gnome-e932a87c5235b90fa671f5b453afd18c94f3b2f3.zip
Do The Right Thing. (R)
Overall changes: Use tabs instead of sequential spaces. Note Author as well as WWW in DESCR. Do not install examples when NOPORTDOCS. Make RUBY, RUBY_VER and RUBY_ARCH variables overridable. ruby-date2: share/doc/ruby/date2/examples/ -> share/examples/ruby/date2/cal.rb textproc/ruby-html-parser: databases/ruby-mysql: devel/ruby-optparse: devel/ruby-property: Install modules under lib/ruby/site_ruby/${RUBY_VER}/ instead of lib/ruby/site_ruby/ or lib/ruby/${RUBY_VER}/ textproc/ruby-rdtool: Install documents in .rd format too. Format optparse's rd file. (Since ruby-rdtool depends on optparse, it cannot be done during optparse's build process. So ruby-rdtool should take care of that when it is installed. :)
Diffstat (limited to 'textproc/ruby-html-parser/Makefile')
-rw-r--r--textproc/ruby-html-parser/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/textproc/ruby-html-parser/Makefile b/textproc/ruby-html-parser/Makefile
index 63606372933c..ebb3d32bb41c 100644
--- a/textproc/ruby-html-parser/Makefile
+++ b/textproc/ruby-html-parser/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: Ruby-html-parser
-# Date created: 7 Aug 2000
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+# New ports collection makefile for: Ruby-html-parser
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
@@ -22,12 +22,16 @@ NO_BUILD= yes
PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-RUBY= ${LOCALBASE}/bin/ruby
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
+
+MODULES= formatter.rb html-parser.rb sgml-parser.rb
do-install:
- @cd ${WRKSRC}; ${RUBY} install.rb
+.for f in ${MODULES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/
+.endfor
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/ruby/html-parser
${INSTALL_DATA} ${WRKSRC}/README.html ${PREFIX}/share/doc/ruby/html-parser/