aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ruby-htmlrepair/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-09-20 13:05:29 +0800
committerknu <knu@FreeBSD.org>2001-09-20 13:05:29 +0800
commit79446d4d3bb116fb6d67827ea088c21a37bd46be (patch)
treed090f65a592a3ab562f5a989c44b99029618b3ad /textproc/ruby-htmlrepair/Makefile
parent1c2cf3b33af8890c4d8cf8811785daf3f53d5d3a (diff)
downloadfreebsd-ports-gnome-79446d4d3bb116fb6d67827ea088c21a37bd46be.tar.gz
freebsd-ports-gnome-79446d4d3bb116fb6d67827ea088c21a37bd46be.tar.zst
freebsd-ports-gnome-79446d4d3bb116fb6d67827ea088c21a37bd46be.zip
Add ruby-htmlrepair, a Ruby library to repair unclosed tags in an HTML
document.
Diffstat (limited to 'textproc/ruby-htmlrepair/Makefile')
-rw-r--r--textproc/ruby-htmlrepair/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/ruby-htmlrepair/Makefile b/textproc/ruby-htmlrepair/Makefile
new file mode 100644
index 000000000000..ab1351a40bbf
--- /dev/null
+++ b/textproc/ruby-htmlrepair/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: htmlrepair.rb
+# Date created: 20 September 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmlrepair
+PORTVERSION= 1.0.1
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.moonwolf.com/ruby/archive/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/htmlsplit.rb:${PORTSDIR}/textproc/ruby-htmlsplit
+
+USE_ZIP= yes
+USE_RUBY= yes
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/htmlrepair.rb ${RUBY_SITELIBDIR}/
+
+.include <bsd.port.mk>