aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ruby-libxml/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-07-12 13:47:44 +0800
committerknu <knu@FreeBSD.org>2002-07-12 13:47:44 +0800
commit57aa55c60e3decfcea936d8c05e4a8816e61adee (patch)
tree4f42360fcc7a3192f05076b59a439051d594e131 /textproc/ruby-libxml/Makefile
parentc0299cd4059095c360c0a9ca189e427e147001d5 (diff)
downloadfreebsd-ports-gnome-57aa55c60e3decfcea936d8c05e4a8816e61adee.tar.gz
freebsd-ports-gnome-57aa55c60e3decfcea936d8c05e4a8816e61adee.tar.zst
freebsd-ports-gnome-57aa55c60e3decfcea936d8c05e4a8816e61adee.zip
Add ruby-libxml (version 0.01), a libxml2 binding for Ruby with both
libxml and Ruby APIs. PR: ports/40392 Submitted by: Sean Chittenden <sean@chittenden.org>
Diffstat (limited to 'textproc/ruby-libxml/Makefile')
-rw-r--r--textproc/ruby-libxml/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/textproc/ruby-libxml/Makefile b/textproc/ruby-libxml/Makefile
new file mode 100644
index 000000000000..7e0c9316b1df
--- /dev/null
+++ b/textproc/ruby-libxml/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ruby-libxml
+# Date created: 09 July 2002
+# Whom: Sean Chittenden <sean@chittenden.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxml
+PORTVERSION= 0.01
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.rubynet.org/modules/xml/ruby-libxml/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-20020709
+
+MAINTAINER= sean@chittenden.org
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/xml2-config:${PORTSDIR}/textproc/libxml2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+#LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+.include <bsd.port.mk>