aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ruby-libxml
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-11 07:19:23 +0800
committermiwi <miwi@FreeBSD.org>2008-01-11 07:19:23 +0800
commitdc4bfc5f2c3fca913aa3ac196c4eb1cd0db07099 (patch)
treeb6dfaba0b25f654f696c899fe54e9216c4121719 /textproc/ruby-libxml
parent0ecc7d34faaf15724b24002bc611779cfcc91e81 (diff)
downloadfreebsd-ports-gnome-dc4bfc5f2c3fca913aa3ac196c4eb1cd0db07099.tar.gz
freebsd-ports-gnome-dc4bfc5f2c3fca913aa3ac196c4eb1cd0db07099.tar.zst
freebsd-ports-gnome-dc4bfc5f2c3fca913aa3ac196c4eb1cd0db07099.zip
- Updates to 0.3.8.4
- Pass maintainship to submitter PR: 118938 Submitted by: Pietro Cerutti <gahr@gahr.ch>
Diffstat (limited to 'textproc/ruby-libxml')
-rw-r--r--textproc/ruby-libxml/Makefile38
-rw-r--r--textproc/ruby-libxml/distinfo6
-rw-r--r--textproc/ruby-libxml/files/patch-ext-xml_extconf.rb11
-rw-r--r--textproc/ruby-libxml/files/patch-extconf.rb11
4 files changed, 37 insertions, 29 deletions
diff --git a/textproc/ruby-libxml/Makefile b/textproc/ruby-libxml/Makefile
index 4cc3ddae767f..ab1f8355da7c 100644
--- a/textproc/ruby-libxml/Makefile
+++ b/textproc/ruby-libxml/Makefile
@@ -6,30 +6,38 @@
#
PORTNAME= libxml
-PORTVERSION= 0.3.2
+PORTVERSION= 0.3.8.4
CATEGORIES= textproc ruby
-MASTER_SITES= http://www.rubynet.org/modules/xml/libxml/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= libxml
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DIST_SUBDIR= ruby
+DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@gahr.ch
COMMENT= A friendly API to libxml for Ruby
-BUILD_DEPENDS= ${LOCALBASE}/bin/xml2-config:${PORTSDIR}/textproc/libxml2
+BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake \
+ xml2-config:${PORTSDIR}/textproc/libxml2 \
+
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
-PLIST_FILES= %%RUBY_SITEARCHLIBDIR%%/xml/libxml.so
-PLIST_DIRS= %%RUBY_SITEARCHLIBDIR%%/xml
-USE_BZIP2= yes
+PLIST_FILES= %%RUBY_SITEARCHLIBDIR%%/xml/libxml_so.so \
+ %%RUBY_SITELIBDIR%%/xml/libxml.rb
+PLIST_DIRS= %%RUBY_SITEARCHLIBDIR%%/xml \
+ %%RUBY_SITELIBDIR%%/xml
+
USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
+USE_ICONV= yes
+USE_LDCONFIG= yes
-INSTALL_TARGET= site-install
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%%PREFIX%%%|${PREFIX}|g' \
+ ${WRKSRC}/ext/xml/extconf.rb
-.include <bsd.port.pre.mk>
+do-build:
+ cd ${WRKSRC} && rake test
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
+do-install:
+ cd ${WRKSRC} && rake install
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/ruby-libxml/distinfo b/textproc/ruby-libxml/distinfo
index 2d79c1c41ae0..205d4d7fdf0e 100644
--- a/textproc/ruby-libxml/distinfo
+++ b/textproc/ruby-libxml/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/libxml-0.3.2.tar.bz2) = a3f23a2a3b1c6fc18d46545f7c294dc9
-SHA256 (ruby/libxml-0.3.2.tar.bz2) = c49bc4a8726cb2043348c426ac72b12e0dc42fc7cebc3c7171610be8e7933b15
-SIZE (ruby/libxml-0.3.2.tar.bz2) = 25758
+MD5 (libxml-ruby-0.3.8.4.tar.gz) = 2190715f1a4779a10d2610c39514ba49
+SHA256 (libxml-ruby-0.3.8.4.tar.gz) = 8b8d091a77cb237789c684f65cb5e48b9920d4b212a7c5e6bd77594547b7809b
+SIZE (libxml-ruby-0.3.8.4.tar.gz) = 59089
diff --git a/textproc/ruby-libxml/files/patch-ext-xml_extconf.rb b/textproc/ruby-libxml/files/patch-ext-xml_extconf.rb
new file mode 100644
index 000000000000..e932689e004d
--- /dev/null
+++ b/textproc/ruby-libxml/files/patch-ext-xml_extconf.rb
@@ -0,0 +1,11 @@
+--- ext/xml/extconf.rb.orig 2006-10-20 13:37:49.000000000 +0200
++++ ext/xml/extconf.rb 2007-12-21 21:01:31.000000000 +0100
+@@ -92,7 +92,7 @@
+ $CFLAGS << ' -Wall'
+ end
+
+-$CFLAGS << ' ' << $INCFLAGS
++$CFLAGS << ' ' << $INCFLAGS << ' ' << "-I /usr/local/include -L /usr/local/lib"
+ $INSTALLFILES = [["libxml.rb", "$(RUBYLIBDIR)", "../xml"]]
+
+ create_header()
diff --git a/textproc/ruby-libxml/files/patch-extconf.rb b/textproc/ruby-libxml/files/patch-extconf.rb
deleted file mode 100644
index 19da6467187b..000000000000
--- a/textproc/ruby-libxml/files/patch-extconf.rb
+++ /dev/null
@@ -1,11 +0,0 @@
---- extconf.rb.orig Sun Dec 8 07:55:26 2002
-+++ extconf.rb Fri Aug 5 19:50:43 2005
-@@ -23,7 +23,7 @@
- dir_config('xml2')
-
-
--unless have_library('m', 'atan')
-+unless have_library('m', 'atan', 'math.h')
- crash('need libm')
- end
-